Support » Plugin: Product Feed PRO for WooCommerce » Fatal error

  • Hi there!

    I´m having a hard time with the plugin. The first time i´ve configurated a feed for Google Shopping it went allright.
    Now I´m trying to configure another google shopping feed for one of my vendors (i´m using Product Vendors for woocommerce), and I keep getting this fatal error.
    The steps i´m following are the usuarl..category mapping and field mapping. In GTIN and MPN i´m using de wooosea fields although the products doesn´t have these codes but I don´t think that´s the problem.
    I tried to fix this by updating the WordPress version to latest (5.4.2) and the problem persist.

    Any idea of how to fix this?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor supportadtribes

    (@supportadtribes)

    Hi,

    Thanks for using our plugin and reaching out to us. Sorry to hear you are experiencing issue with it.

    Could you show me the ‘fatal error’ you are getting and when are you getting this? Straight after the field mapping page?

    The error appears after y click Generate Product Feed (Conversion & Google Analytics – Last step).

    In this link you will see the error message I´m getting
    (Translation: There has been a critical error in your website. Please, check admin mail panel for further instructions. I´ve sent this to my web developer admin and he says that he didn´t recieved any email.) (In the picture you will alse see that WordPress 5.4.2 is available, I´ve already installed it and the same thing is happening).

    error message

    Plugin Contributor supportadtribes

    (@supportadtribes)

    That is not a very descriptive critical error unfortunately. Did you check your WooCommerce fatal error logs of today to see if there is a better error description in there?

    You can find the fatal error logs here:
    https://docs.woocommerce.com/document/finding-php-error-logs/

    I´ve checked actually but the fatal errors doesen´t seem to have to do with Product Feed Pro:

    2020-07-28T19:40:59+00:00 CRITICAL Uncaught Error: Call to undefined function woosync_log_callback_activity() in /home3/z5a0x6j2/expresopolar.com.ar/wp-content/plugins/woosync-premium/external/callbacks.php:918
    Stack trace:
    #0 {main}
    thrown en /home3/z5a0x6j2/expresopolar.com.ar/wp-content/plugins/woosync-premium/external/callbacks.php en la línea 918

    As you can see, refers to woosync-premium, wich is a plugin that isn´t activated right now. What should I do?

    I keep trying to upload my feeds but I´m really stucked. Now I´m getting a 500 error. Could you please help me?

    Thank´s in advance.

    500 error

    Plugin Contributor supportadtribes

    (@supportadtribes)

    Hi,

    When there is nothing in the WooCommerce fatal error logs then the 500 server error could be caused by a firewall or something like cloudflare. Are you running such a firewall/caching plugin?

    This may be a partial installation. I’d try uploading the plugin again using FTP.

    Hi!

    I´ve tried everything:
    1) Deactivate and reactivate the plugin
    2) Delete the plugin and install it again
    3) Deactivating WP Fastest Cache plugin
    4) Uploading the plugin using FTP.
    Unfourtunately, nothing works. Perhaps this has something to do with PHP version / activating or deactivating any PHP extension?

    woosync-premium implies you should contact the author of that plugin directly and give them access to your system to resolve the issue.

    Rather than a partial installation, this may be a partial uninstallation, or there’s something in your theme that still references the missing function.

    Forgot to tell you, woosync-premium has already been uninstalled and the problem persist. I don´t think it has something to do with the theme because I´ve already used this plugin with the actual theme several weeks ago and it worked properly. Do you think it has to do with PHP version / activating or deactivating any PHP extension?

    I noticed that the problem persisted with all plugins being inactive, but if your theme contains any reference to woosync-premium/external/callbacks.php, and this file is still there, this would explain the error.

    You can confirm this by removing or renaming the woosync-premium directory. The error should then change to not finding the file.

    Look through your theme’s functions.php file (and other PHP files) for possible references to woosync functions and inclusions.

    Hi Gal!

    Since I´ve deleted Woosync from my website, I don´t get no more fatal errors referencing this plugin so that shouldn´t be the problem.
    Still, I can´t solve the issue with Product Feed pro (now my fatal error logs are something like this : “Maximum execution time of 30 seconds exceeded”)

    In your PHP settings, change max_execution_time to 300 or more (I use 600).

    Hi!

    We´ve asked the host to push the execution time to the maximum and still, cannot make this plugin work.
    Now we are getting a 500 error.
    Do you think it is possible to solve this issue or should I move to another plugin?

    500 implies there’s something in your error_log or wp-admin/error_log you can look at. Copy and paste it here.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.