• Resolved uomopalese

    (@uomopalese)


    Hi, today i got this error accessing my website:

    [09-Jun-2020 15:48:45 UTC] PHP Fatal error:  Uncaught Error: Class 'WPUM_Field_Avatar' not found in /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-fields/class-wpum-field.php:203
    Stack trace:
    #0 /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-fields/class-wpum-field.php(145): WPUM_Field->setup_field(Object(stdClass))
    #1 /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-database/class-wpum-db-fields.php(215): WPUM_Field->__construct(10)
    #2 /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-admin/class-wpum-notices.php(93): WPUM_DB_Fields->get_fields()
    #3 /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-admin/class-wpum-notices.php(52): WPUM_Admin_Notices->fields_are_empty()
    #4 /home2/giomadtv/public_html/wp-includes/class-wp-hook.php(287): WPUM_Admin_Notices->register_notices('')
    #5 /home2/giomadtv/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #6 /home2/giomadtv/public_ in /home2/giomadtv/public_html/wp-content/plugins/__wp-user-manager/includes/wpum-fields/class-wpum-field.php on line 2033

    Any idea? Thank you
    I updated via FTP to wp-user-manager.2.3.6 but nothing changed

    • This topic was modified 5 months, 3 weeks ago by uomopalese.
    • This topic was modified 5 months, 3 weeks ago by uomopalese.
    • This topic was modified 5 months, 3 weeks ago by uomopalese.
    • This topic was modified 5 months, 3 weeks ago by uomopalese.
    • This topic was modified 5 months, 3 weeks ago by uomopalese.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author WP User Manager

    (@wpusermanager)

    What version were you operating before?

    Can you send me a message via https://wpusermanager.com/contact/ so I can get some more details from you please.

    I checked and it was 2.3.6 but I updated anyway, i saw the last one was updated a couple of hours ago. I renamed the plugin folder and update with yhe new one (error), next I deleted the old one (error), next i moved the updated plugin folder away from the plugin directory. Now I can access my backend, but when I try to edit a page I get a white screen

    • This reply was modified 5 months, 3 weeks ago by uomopalese.
    • This reply was modified 5 months, 3 weeks ago by uomopalese.
    • This reply was modified 5 months, 3 weeks ago by uomopalese.
    Plugin Author WP User Manager

    (@wpusermanager)

    Hmmm, ok – just trying to work out if this update caused the issue. Can you send a message so I can get a database dump of the wpum_ tables from you. Thanks

    Sorry.. where do you want me to send you the dump?

    Plugin Author WP User Manager

    (@wpusermanager)

    Shoot me a message https://wpusermanager.com/contact/ so we can start an email conversation please 👍

    …done

    Hi,
    it turned out that it was a mix of thing: a script inside function.php to defer the load of javascript files has interfered (i guess…) with your plugin. I removed the script and gained access to edit pages. I reinstalled your plugin and it asked to update database tables (it didn’t ask that last time, even if it was 2.3.6). Now I’m back and all is working fine

    • This reply was modified 5 months, 3 weeks ago by uomopalese.
    Plugin Author WP User Manager

    (@wpusermanager)

    Great thanks for the update – glad you resolved it!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.