• Resolved Thea

    (@dorothy1508)


    I tried to install Ninja Shop plugin on my website and it crashed my site. The message I got is as follows (my website name removed where necessary):

    Fatal error: Uncaught exception ‘IronBound\DB\Exception’ with message ‘Specified key was too long; max key length is 1000 bytes’in /home/…/wp-content/plugins/ninja-shop/vendor/ironbound/db/src/Manager.php:206 Stack trace: #0 /home/…/wp-content/plugins/ninja-shop/ninja-shop.php(305): IronBound\DB\Manager::maybe_install_table(Object(ITE_Transaction_Line_Item_Table)) #1 [internal function]: it_exchange_install_tables_on_activate(”) #2 /home/…/wp-includes/class-wp-hook.php(286): call_user_func_array(‘it_exchange_ins…’, Array) #3 /…/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #4 /home/…/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /home/…/wp-settings.php(450): do_action(‘init’) #6 /home/…/wp-config.php(89): require_once(‘/home/… in /home/…/wp-content/plugins/ninja-shop/vendor/ironbound/db/src/Manager.php on line 206

    • This topic was modified 7 months ago by  Thea.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thea

    (@dorothy1508)

    Just to clarify, this occurred on activation.

    Plugin Author Kyle B. Johnson

    (@kbjohnson90)

    @dorothy1508 This issue has been resolved (to the best of my knowledge) for a few releases.

    If this is still an issue for some installations then I’d really like to get this resolved as soon as possible.

    Can you confirm which version you installed?

    Also, can you provide additional details about your website environment- host, PHP version, etc?

    You can provide this information securely using our support system: https://getninjashop.com/contact/.

    I have had the same error which has taken down my site with the version which is currently downloadable from wordpress! Now I can’t get into the admin panel due to this badly tested plug-in!

    I have contacted you via the website but no response.

    Plugin Author Kyle B. Johnson

    (@kbjohnson90)

    Peter,

    I see where your ticket came in yesterday, I’m sorry that we did not respond earlier than we did.

    We have come across different database configurations that are conflicting with our codebase – which we have been patching at we come across them.

    Please check for v1.1.6 which is the latest release (2018.11.08) with the latest known fix.

    Thea

    (@dorothy1508)

    Brilliant! thank you for your care and attention in solving this problem, especially since this is a free plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error’ is closed to new replies.