• Resolved Workshopshed

    (@workshopshed)


    The plugin is causing a fatal error which in turn causes various ajax errors around the Admin screen such as not being able to view the media library from the edit post screen

    PHP Fatal error: Can’t use function return value in write context in /mysite/wp-content/plugins/backwpup/inc/class-destination-ftp.php on line 285

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter Workshopshed

    (@workshopshed)

    p.s. have been using the plugin for many years without issue.

    Wordpress – 4.9.6

    Plugin Support duongcuong96

    (@duongcuong96)

    @workshopshed

    the problem because of we suddenly upgrade GuzzleHttp to a newer version that dropped support for 5.4 πŸ™

    Sorry, but we currently try to fix it and going to release the new fixed version as soon as possible, really sorry for any problem happens to you πŸ™

    For a temporary fix, Please install a plugin called WP Rollback(https://wordpress.org/plugins/wp-rollback/), after that, go to plugin list -> find BackWPUp and press Roll back to the 3.4.5 version

    Or better, tell your hoster to upgrade PHP version to 5.6 or 7.0.

    Sorry again for all the troubles you got πŸ™

    Thread Starter Workshopshed

    (@workshopshed)

    Thanks I’ll give those a go.

    Had a similar issue after upgrading to 3.5.0. We are using Ajax Load More, and as a result of updating BackWPUp to 3.5.0 our pages were missing items that Ajax Load More would load and display because of http 500 errors. Deactivating BackWPUp fixed the problem, but for an operational solution I reverted back to the pervious BackWPUp version 3.4.5.

    Also, I believe updating to WP 4.9.6 will also fix the issue, allowing BackWPUp 3.5.0 to work correctly.

    Updating to WP 4.9.6 did not help me.

    Thread Starter Workshopshed

    (@workshopshed)

    Upgrading to PHP 5.6.36 resolved this

    Plugin Support duongcuong96

    (@duongcuong96)

    @mmgh
    You need to upgrade PHP version to at least 5.6( just tell your hoster about that ).
    Or like I said, for now, please downgrade this plugin πŸ™

    Plugin Support duongcuong96

    (@duongcuong96)

    @mmgh
    You need to upgrade PHP version to at least 5.6( just tell your hoster about that ).
    Or like I said, for now, please downgrade this plugin πŸ™

    Will do. Actual version is 5.4.45

    • This reply was modified 4 years, 2 months ago by mh.

    Hi @all,

    we have a new version on github fixing bugs of 3.5.0. You can download it here https://github.com/inpsyde/backwpup/archive/master.zip.
    Would be great if we get some feedback before we release on wordpress.org.

    Thanks a lot for your help!

    I tried the github version and it corrected my issue with Ajax Load More.

    My earlier comment about updating to WP 4.9.6 also appears to have been incorrect. I was working on a prototyping server which apparently had PHP 5.6 on it.

    Plugin Support duongcuong96

    (@duongcuong96)

    @mariogiannini
    @workshopshed
    The new 3.5.1 version has been released with bugs fixed, please update as soon as possible.
    Thank you!

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support πŸ˜€
    https://wordpress.org/support/plugin/backwpup/reviews/

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal Error’ is closed to new replies.