Support » Plugin: Connections Business Directory » Fatal Error

  • Resolved godthor

    (@godthor)


    The site this is on is running PHP 5.6, so it’s not a version issue if only 5.3 is required. That being said, I’m seeing this error come up.

    [04-Apr-2018 16:47:30 UTC] PHP Parse error: syntax error, unexpected '::' (T_PAAMAYIM_NEKUDOTAYIM) in /home/jaretcoh/public_html/wp-content/plugins/connections/includes/class.constants.php on line 23

    If I look at that file I see this:

    define( 'CN_CURRENT_VERSION', Connections_Directory()::VERSION );

    I don’t much feel like chasing code, but there’s something not right there it would seem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Also, the site is using v8.16, updated 5 days ago.

    Plugin Author Steven

    (@shazahm1hotmailcom)

    PLease log in to your site using FTP and delete the ../wp-content/plugins/connections/ folder and then reinstall as you normally would. You data is safe.

    Alternatively you can edit the line:

    define( 'CN_CURRENT_VERSION', Connections_Directory()::VERSION );

    to be this:

    define( 'CN_CURRENT_VERSION', ConnectionsLoad::VERSION );

    Either will resolve the issue.

    Hope this helps!

    ps. More importantly, you should request that the web host update your site to PHP 7.1. It is must faster and for more resource efficient. PHP 5.6 is on “life support” only receiving security fixes until the end of the year. After that, it will be unsupported and potentially insecure.

    Perfect, thank you.

    I agree about PHP 7. It’s the next step now this is going again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal Error’ is closed to new replies.