Support » Plugin: a3 Lazy Load » Fatal error?

  • Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/place2home/domains/mywebsite.com/public_html/wp-content/plugins/a3-lazy-load/admin/admin-ui.php on line 37

    Was an error that is has been solved thanks to the A3 Lazy Load developers.

    • This topic was modified 4 years, 6 months ago by DutchMan0.
    • This topic was modified 4 years, 6 months ago by DutchMan0.
    • This topic was modified 4 years, 6 months ago by DutchMan0.
    • This topic was modified 4 years, 6 months ago by DutchMan0.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Steve Truman

    (@a3rev)

    Hello @dutchapex

    Sorry to hear about your issue.

    You have seen that issue because your host server is running an outdated and unsupported PHP Version? Probably version 5.5 or earlier – this is very bad.

    PHP stopped support for 5.5 1 year and 7 months ago and strongly recommend that it is not used due to known security vulnerabilities – see here

    http://php.net/eol.php

    WordPress Requirements state that to run WordPress system config should be
    PHP version 7.2 or greater
    MySQL version 5.6 or greater OR MariaDB version 10.0 or greater
    HTTPS support

    You can read more about that here https://wordpress.org/about/requirements/

    On that WordPress link there is a sample email that you can use to send to your host to upgrade your system. As soon as you upgrade to PHP 5.6 or higher you will not have the issue and your server will be much more secure.

    Regards
    Steve

    Thread Starter DutchMan0

    (@dutchapex)

    Hi Steve,

    My response was most inappropriate.
    After hours of working on a website, I downloaded and activated a3 Lazy Load.
    Seeing a parse/syntax error kind of pissed me off.
    I guess I forgot the netiquette rules. My apologies.

    On all my servers, with different hosting, web-, reseller- and VPS hosting, I run PHP 7 and higher. It’s faster and more stable. So, that doesn’t seem to be the problem.
    I just test your plugin again, with PHP version 7.2, I can not reproduce the error.
    It is not showing up anymore. Maybe something was wrong with my hosting, a cache plugin produced the error or there was a conflict with another plugin.

    Anyway, if you tell me how I can change my WordPress rating for your plugin, I will change it.

    Have a great day,

    DutchMan0 (@dutchapex)

    Plugin Author Steve Truman

    (@a3rev)

    @dutchapex,

    Thank you! – I am sure with running PHP 7 and higher that you would see that issue – the Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in is the error message that shows when the PHP version is less than 5.5+ or older.

    I don’t think it would be a conflict with another plugin or a theme. As you are running with with different hosting, web, reseller and VPS – it might be useful to check this with the host of the site where you saw that issue:

    Some servers allow the admin to change the PHP Version via php.ini , but that won’t take effect if the php.ini on root folder don’t change. My guess is that if you check that (or ask your host to check it) you will see that the PHP version is actually < 5.5 on that server (which is bad).

    But of course if you can now activate a3 Lazy Load on a site on that server without seeing the fatal Error than it is not the case and I am out of ideas.

    @dutchapex I appreciate your offer to change your review – I have made you a 13 second video to show you how to do that. I am using a review I wrote just last week for another developers plugin to show you.

    https://screencast-o-matic.com/watch/cFeYV2DUlu

    Regards
    Steve

    Plugin Author Steve Truman

    (@a3rev)

    @dutchapex

    Thank you!

    Steve

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal error?’ is closed to new replies.