Support » Plugin: W3 Total Cache » Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine

  • I got this message today, after trying to save a post. I’m having the same after trying to empty the cache, too. I did restore all settings in W3TC and all was fine. After that, I switched to mine setup switching all settings one by one. All looked good and I continued working, while suddenly I got the same error message. Today I updated the plugin and installed Cloudflare together with some changes in the settings. I’m not sure which of them could cause the problem.

    Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine ‘ in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(222): W3TC\Cdnfsd_Core->get_engine() #1 [internal function]: W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /home/swansph/public_html/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array) #3 /home/swansph/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #4 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters(‘w3tc_flush_exec…’, Array) #5 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #6 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(194): W3TC\CacheFlush->execute_delayed_operations() #7 [internal function]: W3TC\CacheFlush->execute_delay in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48

    Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine ‘ in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(222): W3TC\Cdnfsd_Core->get_engine() #1 [internal function]: W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /home/swansph/public_html/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array) #3 /home/swansph/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #4 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters(‘w3tc_flush_exec…’, Array) #5 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #6 [internal function]: W3TC\CacheFlush->execute_delayed_operations() #7 /home/swansph/public_html/wp-includes/class-wp-hook.php(284): call_user_func_array(Array, Array) #8 /home/swans in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48

    • This topic was modified 1 year, 11 months ago by swan_.
    • This topic was modified 1 year, 11 months ago by swan_.
Viewing 3 replies - 31 through 33 (of 33 total)
  • I’ve been using both Cloudflare and W3 Total Cache for a number of years and it’s been in the past that you can implement CF either through W3 Total Cache OR through CF itself. I’ve always bypassed the W3 Total Cache approach and it never caused problems until recently when the cdnfsd logic was modified.

    In summary, my advice is to turn off the “cdnfsd enabled” switch by updating master.php (as mentioned in the prior posts) and make sure you don’t have the cloudflare extension activated (found in the EXT options at the bottom of the performance options in W3 Total Cache).

    Then, go to your Cloudflare account and make sure your nameservers are using the ones assigned by them.

    • This reply was modified 1 year, 10 months ago by Steve D.
    • This reply was modified 1 year, 10 months ago by Steve D.

    Vincent Verloop
    {Just edit:
    /www/wp-content/w3tc-config/master.php

    “cdnfsd.enabled”: “0”
    “cdnfsd.engine”: “CloudFlare”

    Then clear Cache.
    If you can clear cache, the problem is solved.}

    Should we add these lines ?

    I had exactly the same issue. I used Cloudflare in the past, but not currently and had the extension disabled – yet still had the cdn error outlined in this thread.

    Thanks to all who worked on solving this.

Viewing 3 replies - 31 through 33 (of 33 total)
  • The topic ‘Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine’ is closed to new replies.