Support » Plugin: W3 Total Cache » Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine

  • I got this message today, after trying to save a post. I’m having the same after trying to empty the cache, too. I did restore all settings in W3TC and all was fine. After that, I switched to mine setup switching all settings one by one. All looked good and I continued working, while suddenly I got the same error message. Today I updated the plugin and installed Cloudflare together with some changes in the settings. I’m not sure which of them could cause the problem.

    Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine ‘ in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(222): W3TC\Cdnfsd_Core->get_engine() #1 [internal function]: W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /home/swansph/public_html/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array) #3 /home/swansph/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #4 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters(‘w3tc_flush_exec…’, Array) #5 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #6 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(194): W3TC\CacheFlush->execute_delayed_operations() #7 [internal function]: W3TC\CacheFlush->execute_delay in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48

    Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine ‘ in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(222): W3TC\Cdnfsd_Core->get_engine() #1 [internal function]: W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /home/swansph/public_html/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array) #3 /home/swansph/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #4 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters(‘w3tc_flush_exec…’, Array) #5 /home/swansph/public_html/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #6 [internal function]: W3TC\CacheFlush->execute_delayed_operations() #7 /home/swansph/public_html/wp-includes/class-wp-hook.php(284): call_user_func_array(Array, Array) #8 /home/swans in /home/swansph/public_html/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48

    • This topic was modified 1 year, 7 months ago by  swan_.
    • This topic was modified 1 year, 7 months ago by  swan_.
Viewing 15 replies - 16 through 30 (of 33 total)
  • Same error. Uninstall. 3 days to address a critical, site crashing issue is unacceptable.

    same error for me too

    same error for me too

    same here, have gone back to a version 0.9.5.4.

    Amazing such a major plugin can have a show stopper bug like this for days now without even a comment from the developer to acknowledge the bug.

    Its previous update was 8 months ago, so I guess this plugin is not a priority for the developer anymore.

    Had to roll back as well. :/

    Was able to circumvent the problem by using the previously described techniques, thanks you guys for that! However, this is getting to be problematic – my site, which is getting the most traffic, is scoring in 30% range in page speed. I decided to buddy up with a cdn, cloudfront being my choice. Trying to hook it up though, the old problems with this plugin have resurrected. When I deactivate the W3 Total Cache plugin, everything is even worse.

    Alas, woe is me!

    Any pointers would be greatly appreciated – site is fusion-culinaire.com

    Merry XBox Xmas!

    • This reply was modified 1 year, 6 months ago by  Steve D.

    Hello Steve,
    It seems from the GTMetrix of your home page that most assets are returning either a MISS or an EXPIRED for their CloudFlare cache. Also, your page/assets are loading via http instead of https, which is not the desired outcome once CloudFlare is enabled. I’d suggest checking your Cloudflare settings.
    Also, since you disabled W3 Total Cache, have you enabled another server-level caching? I’ve disabled my W3 Total Cache and subsequently installed WP Super Cache with preloading enabled, plus Autoptimize. I’m very happy with the results.
    I’m not an expert, but I hope my recent experience may help you in some way.
    Merry Xmas!

    Thanks cbrandt,

    Yeah, GTMetrix is what started this entire escapade. Perhaps I shouldn’t worry about the page speed, after all, if it’s “working”, no need to “fix it” right? Will attempt your advice but it sure would be nice to have this plugin working like it should. I’ve got over a dozen sites using W3 Total Cache, I’ll stick with em!

    I’m having the same issue. But for me, everything seems to work fine, but if I have Object Caching enabled, that’s when I start to get the errors. So for now I’ll either have to rollback the version or turn off object caching for now.

    Hopefully that helps some people and works the same for them.

    Same issue for me too. I fixed it with @nigrosimone solution. Hope it will be updated soon!

    • This reply was modified 1 year, 6 months ago by  Sociality.
    • This reply was modified 1 year, 6 months ago by  Sociality.

    I have the same problem. I did not try any of the fixes as this shouldn’t be auto selected for no real reason.

    Just edit:
    /www/wp-content/w3tc-config/master.php

    “cdnfsd.enabled”: “0”

    Then clear Cache.
    If you can clear cache, the problem is solved.

    You have to pay for FSD CDN to use it, so why is it enabled by default?

    Correction:

    Just edit:
    /www/wp-content/w3tc-config/master.php

    “cdnfsd.enabled”: “0”
    “cdnfsd.engine”: “CloudFlare”

    Then clear Cache.
    If you can clear cache, the problem is solved.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘Fatal error: Uncaught exception ‘Exception’ with message ‘unknown engine’ is closed to new replies.