Support » Plugin: Protect the Children! » Fatal Error

  • Resolved akanehoikuen

    (@akanehoikuen)


    I’m sad.

    I got the error when I activated the plugin.

    The Error was:

    Fatal error: Can’t use function return value in write context in /home/xxxx/xxxxxxx/wp-content/plugins/protect-the-children/index.php on line 84

    I found out This plugin !! But,I’m sad.

    I am using the wordpress 4.8.2-ja.

    Please Help me.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Self resolved!!

    This error is concern with the PHP’s versions.

    This error is not occur with PHP 5.5 above.

    The solve is here.
    https://stackoverflow.com/questions/17139264/cant-use-function-return-value-in-write-context

    My fixed cords are …
    ————————–
    83: // See if the parent post has the protect child option enabled
    84: $get__post__meta=get_post_meta($parent_id, ‘_protect_children’, true);
    85: if (empty($get__post__meta) || get_post_meta($parent_id, ‘_protect_children’, true) == “off”)
    86: return;
    ————————–

    Thank you !!

    Sorry!!

    It is yet error!!

    This is right!
    ————————-
    83: // See if the parent post has the protect child option enabled
    84: $get__post__meta=get_post_meta($parent_id, ‘_protect_children’, true);
    85: if ($get__post__meta == “” || $get__post__meta == “off”)
    86: return;
    ———————————————-

    Thank you!!

    Plugin Author Miller Media

    (@millermedianow)

    Hi @akanehoikuen, thank you for passing this along and apologies for any delays on this. We are taking a look at this now. For starters, we are going to write in a check to require PHP 5.5 and above for the plugin. I will let you know when we have updated these. Thanks!

    Plugin Author Miller Media

    (@millermedianow)

    To be clear, we are not supporting PHP5.5 since it is at ‘end of life’ in it’s development cycle. http://php.net/supported-versions.php

    Plugin Author Miller Media

    (@millermedianow)

    This has been resolved by removing support for PHP 5.5 and lower. Thanks for letting us know!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal Error’ is closed to new replies.