Support » Plugin: Timeline Express » Fatal error

  • Resolved hmmcrunchy

    (@hmmcrunchy)


    hi there the 1.5.1 update has thrown this for me

    Parse error: syntax error, unexpected ‘[‘ in *sitename*/wp-content/plugins/timeline-express/lib/classes/class-timeline-express-admin.php on line 481

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Code Parrots

    (@codeparrots)

    Hi @hmmcrunchy,

    Thank you for reporting the issue here. It sounds like your server is running an older version of PHP, one that is pre-5.6.

    You should see the issue resolve itself if you update the version of PHP on your server to version 5.6 or later. We will get this patched up and fixed to prevent this from happening on other users sites running older versions of PHP.

    It is also worth noting that any versions pre-5.6 are insecure as they are no longer supported and no longer receiving security updates.

    It’s recommended that you update to at least version 5.6 – which should help resolve this warning.

    Let us know if that helps resolve your issue.

    svignello

    (@svignello)

    Hi,

    I have got the same issue and my web hosting admin has not planned a PHP upgrade.
    BTW, was there a note warning us that this new version of timeline-express plugin required a 5.6 PHP upgrade ?

    Hope a fix very soon,

    Regards,

    Serge

    Plugin Contributor Code Parrots

    (@codeparrots)

    Hi @serge,

    It looks like it does require php 5.6 or later but let us do some testing and see what’s going on. We can patch things up and get it pushed out today for you.

    We will post back here when we’ve had a chance to ship the new version.

    Plugin Contributor Code Parrots

    (@codeparrots)

    Hi, we are bundling up and pushing out a 1.5.2 release which should have this resolved for all of you. We have tested all the way back to PHP 5.2 with the free version, and have found no noticeable issues.

    We will post back here when the release is public on WordPress.org.

    Thanks!

    Thread Starter hmmcrunchy

    (@hmmcrunchy)

    Thanks guys much appreciated will give this a test asap

    Plugin Contributor Code Parrots

    (@codeparrots)

    Hi @hmmcrunchy,

    We’ve gone ahead and pushed out the 1.5.2 patch to the plugin repository. You should see an update in the next hour or so. Once you update to 1.5.2 you should no longer run into any warnings on activation.

    If for some reason you are still having issues activating the plugin please don’t hesitate to post here and let us know and we’d be more than happy to help out as best we can.

    Thank you for reporting the issue and allowing us to fix it!

    Thread Starter hmmcrunchy

    (@hmmcrunchy)

    that works perfectly thanks guys!

    svignello

    (@svignello)

    Hi @codeparrots,

    Thanks a lot. It works great.
    Really appreciate your work.

    Serge

    Plugin Contributor Code Parrots

    (@codeparrots)

    @hmmcrunchy @svignello,

    No problem at all. Glad we could help get the issue cleared up in such a short time.

    Have a great week!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal error’ is closed to new replies.