Support » Plugin: Content Resharer » Fatal Error

  • “Fatal error: Using $this when not in object context in [..]/wp-content/plugins/wpsite-content-resharer/wpsite-content-resharer.php on line 447”

    This is what I see when I click the Content Resharer tab in the admin.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author 99robots

    (@99robots)

    Hi @carolemagouirk – Can you provide a few more details:

    1) Did this occur after upgrading?
    2) What version are you running?
    3) Try deactivating, and reactivating the plugin? Same issue?

    We can try to replicate it on our side based on your response. Thank you.

    1) I don’t know when it stopped but it hasn’t been posting to twitter for a few months. After the recent update, it started showing the error.

    2) Version 2.2.0

    3) Same issue.

    I tried deactivating all of my other plugins and it still has the same error.

    Plugin Author 99robots

    (@99robots)

    @carolemagouirk – thanks for the information and confirmation. The team is looking into it as we speak and have already identified a fix. We should have something out by tomorrow end of day to resolve this issue. Apologies for the inconvenience. Thank you.

    Plugin Author 99robots

    (@99robots)

    @carolemagouirk – Thank you for your patience. We have updated the plugin and a new version (2.2.1) should be available for you which will fix the issue that has been faced.

    I’ve updated the plugin but now it gives me a new fatal error when I click “reshare now”.

    “Fatal error: Class ‘WPsiteTwitterReshare’ not found in [..]/wp-content/plugins/wpsite-content-resharer/include/reshare-accounts/reshare-twitter.php on line 4”

    Plugin Author 99robots

    (@99robots)

    Hello – Our team was not able to replicate the error on a new WP install. Therefore, would you mind deactivating all plugins and letting us know if the issue persists?

    Additionally, please check your PHP version to ensure it meets the requirement. You will need at least PHP Version 5.4 or greater (older PHP versions are not recommended or supported)

    Same issue after deactivating all plugins and switching to one of the default wordpress themes.

    I don’t know what php version I have, but everything else runs perfectly fine.

    Also, nothing shows up when I go to edit my twitter account. There’s 4 tabs and a save button, but nothing shows up between them.

    Is there some way to completely remove this plugin so I can try a clean reinstall?

    Plugin Author 99robots

    (@99robots)

    Hello, Thank you for your patience.

    1) To check your current PHP version, please follow the steps below:

    Enter “Display PHP Version” in the text box and click Search Plugins. In the list of Plugins click Install Now next to the Display PHP Version Plugin. Go to your WordPress dashboard page and look next to your WordPress version to see what PHP version is running.

    The link to the plugin is https://wordpress.org/plugins/display-php-version/.

    2) For a clean reinstall, first remove your plugin, please go to the Plugins section > Installed Plugins > Delete. After that, please install the plugin again.

    Please let us know if you have any more issues.
    Thank you

    Thank you for your help.

    I forgot I already have a plugin that displays my info, my PHP version is 5.6.29. I was too lazy to look and you totally caught me.

    I’ve deleted and reinstalled the plugin twice that exact same way and yet it always shows that I have twitter activated.

    Is there a table in the database I can drop to have a completely clean install?

    Is there a table in the database I can drop to have a completely clean install?

    Plugin Author 99robots

    (@99robots)

    Hi Carole – Since we only authorize the networks following the rules of each network, you’ll find the workaround to remove Twitter is to just revoke access to the application.

    How to revoke access or remove an application
    1) Sign in to your account on twitter.com.
    2) Go to the Apps tab in your account settings. All of the applications connected to your account will be displayed. You can see the specific permissions that each app has to use your account listed under the application name and description.
    3) If you’d like to disconnect an application from your account, click the Revoke Access button next to the application.

    Alternatively, check your APPS as you created one specifically for this plugin. Remove that app, and that should automatically disconnect / prevent the twitter activation / connection. Then, you can simply create a new app and retrieve new tokens if you wish to reconnect the Twitter account.

    Please let us know if that works. Thank you.

    Done and done, still no difference.

    The ID for my twitter account in the plugin dashboard is “Twitter” somehow.

    Clicking “Deactivate” does nothing except change the word to “Activate” and vice versa.

    I’ve removed every option in my database that has anything to do with this plugin, deactivated, deleted, reinstalled and the ID still says “Twitter”.

    Plugin Author 99robots

    (@99robots)

    The only other way to do this is to remove the options from wp_options.
    For example, the option_name wpsite_twitter_reshare_settings
    You can remove any option that is prefixed with wpsite_.

    Though when deleting the plugin, it does automatically remove these options. However, it seems to not work for you for some reason or another.

    I did a search, but there were no options from the options table with “wpsite” as the option_name.

    Anyone else having this problem or is it just me?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Fatal Error’ is closed to new replies.