Support » Plugin: Smartsupp Live Chat » Fatal Error

  • Resolved meaelien

    (@meaelien)


    Hi I have installed the smartsupp wordpress client plugin on some of my websites, and it works great, but yesterday one of them stopped working, after some inspection I find out that the cause was the smartsupp plugin. After I turned it off, I went threw All of my sites which used this plugin but none of them was influenced, so I tought it was a once in life thing. But today another site crashed and the problem was the same…

    PHP message: PHP Fatal error: require_once(): Failed opening required ‘/var/www/clients/client7/web9/web/wp-content/plugins/smartsupp-live-chat/public/../vendor/autoload.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/clients/client4/web6/web/wp-content/plugins/smartsupp-live-chat/public/class-smartsupp.php on line 16

    None of the files had been deleted, everything was the same, nothing changed since the last day (when it worked normally).

    I tried to overwrite it with a fresh copy of the plugin with no luck.

    Could you help me find out what caused it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Smartsupp

    (@smartsupp)

    Hi @meaelien

    Sorry to hear there is some issue but you are the first one to report anything like this. We did not do any changes to to our plugin recently.

    If it worked, the plugin is still the same, there must be other change, plugin, udpate, theme, etc. that had something to do with this and maybe is creating an issue.

    Could you give me more details? WP version, maybe recently installed plugins, themes you use?

    Also, could you test it the way, deactivate all plugins, activate Smartsupp, activate one plugin after another until it gives you error. This would be simple and fast way to debug it from your side.

    [ Signature moderated ]

    • This reply was modified 4 years, 2 months ago by Smartsupp.
    • This reply was modified 4 years, 1 month ago by Jan Dembowski.
    Thread Starter meaelien

    (@meaelien)

    Hi,

    Thanks your reply, the weird thing is that the problem is not always reproduceable. One of the sites had flatsome the installed the other had balszok (with visual composer), one of them had ssl enabled the other not. Maybe the only common thing is both of them had woocommerce installed, and wprocket cache, the wordpress version was 4.7 both of them.

    I will try to test it but because both of them are shops with daily visitors (and costumers) I can’t “shut down” the site for testing purposes now.

    Plugin Author Smartsupp

    (@smartsupp)

    Hi,

    thanks for more info.
    For all listed theme, visual composer, woocommerce and WP version, similar combinations and also seperately, it is tested and works.

    There must be some other issue related to this, occuring on your sites, some specific condition for this to start the problem.

    Very difficult for us to test it. It would need more info.

    [ Signature moderated ]

    Plugin Author Smartsupp

    (@smartsupp)

    Hi Meaelien,

    you can also try to install older version of our plugin which does not have this issue. Check it out and let me know in case you need more info.

    https://downloads.wordpress.org/plugin/smartsupp-live-chat.2.8.zip

    [ Signature moderated ]

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Side note to @smartsupp I don’t want to have a protracted conversation about this but please do not use signatures in these forums again.

    http://codex.wordpress.org/Forum_Welcome#Signatures

    Plugin Author Smartsupp

    (@smartsupp)

    Hi Jan,

    thank you for letting us know.

    Thread Starter meaelien

    (@meaelien)

    Hi Smartsupp,

    I tried to reproduce the error, but I can’t so I don’t know what caused it. If i ever met with it I will test it deeply, and I will let you know so that you can test it if it caused by the plugin.

    Thank for your answers.

    Plugin Author Smartsupp

    (@smartsupp)

    Hi,

    thanks for getting back to us with more info.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fatal Error’ is closed to new replies.