Support » Plugin: Amazon Post Purchase » Fatal error

  • Hi there,
    I am on WP 4.1.1
    I get the following error when trying to activate your plugin:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /home/jonathan/public_html/site/wp-content/plugins/amazon-post-purchase/include/classes/APP_Widget.class.php on line 21

    Is this a known issue? Is there anything I can do about it?

    Thanks.

    https://wordpress.org/plugins/amazon-post-purchase/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor loudlever

    (@loudlever)

    Hi – with which version are you getting this error? I’m unable to reproduce with the latest plugin version and WP version you mention.

    Also – which browser are you using?

    Plugin Contributor loudlever

    (@loudlever)

    @inspired888 – has your issue been resolved?

    I have the same problem. WordPress 4.3.1 and Amazon Post Purchase 2.0.0.

    Line 81 in APP_Admin.class.php
    $opts = get_option(AMZNPP_PLUGIN_OPTTIONS)[options];

    and line 21 in APP_Widget.class.php
    $this->options = get_option(AMZNPP_PLUGIN_OPTTIONS)[options];

    Both throw mentioned parse error because of the [options]. I’m not sure if the syntax somehow changed in the last WP versions, but get_option(AMZNPP_PLUGIN_OPTTIONS)[options] seems to not be valid anymore.

    Plugin Contributor loudlever

    (@loudlever)

    Hi – looking at this. Will post back when we can reproduce.

    Is this a new install, or an upgrade?

    Plugin Contributor loudlever

    (@loudlever)

    @sm0k1nggnu – what version of PHP are you running?

    PHP version 5.3.28

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error’ is closed to new replies.