WordPress.org

Forums

[resolved] Fatal Error (13 posts)

  1. luciole135
    Member
    Posted 1 year ago #

    On dashboard->plugins

    Fatal error: Call to protected method WP_List_Table::get_pagenum() from context '' in C:\wamp\www\wordpress\wp-admin\plugins.php on line 16

    with WAMP PHP 5.2.5

  2. Can you confirm you're testing on WP 4.0-beta, and using a default theme? If not, please test again on the default theme (TwentyFourteen).

    Also make sure your install of the beta was complete.

    Edit: This is likely the same issue:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'WP_Comments_List_Table::_js_vars' was given in C:\wamp\www\wordpress\wp-includes\plugin.php on line 488

    with WAMP Apache 2.2.6 PHP 5.2.5

    Merging your posts to make it a little easier on us :)

  3. luciole135
    Member
    Posted 1 year ago #

    It's on 4.0 beta1, with my child-theme.
    But with Twenty fourteen, same error.

    There is a problem with the file : wp-includes is missing on download.

    I use french version "fr_FR"

  4. luciole135
    Member
    Posted 1 year ago #

    Now, i have all the files of the french version and it's the same error.

  5. Wait, what file is missing on download?

  6. luciole135
    Member
    Posted 1 year ago #

    Previously, the entire file wp-includes missing.
    Now, this entire file is present, but the error, it is still there.

  7. Okay, can you delete the wp-includes folder and wp-admin, and then manually download and install beta? I think you have a bad download and it's not fixing itself.

  8. luciole135
    Member
    Posted 1 year ago #

    I manually downloaded the archive:
    https://wordpress.org/wordpress-4.0-beta1.zip
    found on this page of wordpree-fr.net :
    http://www.wordpress-fr.net/2014/07/11/wordpress-4-0-beta-1-est-disponible/

    It's still the same error on apache 2.2.6 PHP 5.2.5

    I trying another version of PHP.

  9. luciole135
    Member
    Posted 1 year ago #

    On a new install with easyPHP 14.1
    PHP Version : 5.4.24 / 32Bit OS
    There is no error.

    But For an update on WAMP with PHP 5.2.5 from WordPress 3.9.1, there is an error.

  10. luciole135
    Member
    Posted 1 year ago #

    On a new install on WAMP server 2.0 with PHP 5.2.5 there is the error :
    Warning: Wrong parameter count for array_unique() in C:\wamp\www\wordpress4\wp-includes\taxonomy.php on line 2348

  11. The reason I asked is that you said the wp-includes folder (not file, it's a folder, it should have a ton of files inside :) ) was missing, so that implies you had a bad install.

    Okay, so this looks like a PHP 5.2.5 issue which would explain why I can't see it.

  12. luciole135
    Member
    Posted 1 year ago #

    Sorry for my English, it is Google that translates.

  13. Totally alright!

    Created https://core.trac.wordpress.org/ticket/28843 for tracking

    I'm marking this post as resolved since we have a trac ticket. You can follow the ticket if you want.

Topic Closed

This topic has been closed to new replies.

About this Topic