WordPress.org

Forums

Challonge
[resolved] Fatal Error (8 posts)

  1. Soajaisou
    Member
    Posted 1 year ago #

    I am new to using your plug-in and when i get it all set up I go in and try the widget out and I am getting something weird.

    Fatal error: Call to a member function asXML() on a non-object in /home2/lexxo/public_html/wp-content/plugins/challonge/class-challonge-api-adapter.php on line 27

    How do I fix this or is this a error in the file itself?

    https://wordpress.org/plugins/challonge/

  2. zavaboy
    Member
    Plugin Author

    Posted 1 year ago #

    I will make and include a fix for this in my next update. To avoid the error, try setting the caching to "0". That should do it until I get it fixed. (I haven't tested that workaround, but I don't see why it wouldn't work.)

    Thanks for the feedback! :)

  3. Soajaisou
    Member
    Posted 1 year ago #

    Where do I do this?

  4. zavaboy
    Member
    Plugin Author

    Posted 1 year ago #

    In administration:
    Look in Settings > Challonge and where you see "Cache API responses for", set that number to zero.

  5. Soajaisou
    Member
    Posted 1 year ago #

    Okay it seems to be working but its not pulling up tournaments that I have on there. Hmm I am sorry I am not used to this type of plug-in.

  6. zavaboy
    Member
    Plugin Author

    Posted 1 year ago #

  7. Soajaisou
    Member
    Posted 1 year ago #

    It works great thanks for your help!

  8. zavaboy
    Member
    Plugin Author

    Posted 1 year ago #

    This issue should now be fixed in version 1.1.1. You should be able to use caching again without getting errors.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Challonge
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.