Support » Fixing WordPress » Fatal Error.

  • russhowepti

    (@russhowepti)


    Hi guys,
    Since I switched hosting to GoDaddy 10 days ago, my blog at russhowepti.com keeps on popping up with an error message:

    Fatal error: Cannot call overloaded function for non-object in /home/russhowe/public_html/RussHowePTI.com/wp-includes/user.php on line 217

    Before I switched I downloaded a back-up of my posts/pages and uploaded it to my GoDaddy when I switched so I got all my old posts back. But this message pops up all the time. It’s either on constantly, or as soon as somebody clicks on a few pages it eventually pops up.

    Spoken to GoDaddy customer services who had absolutely no idea what it was.

    I looked at the file which is listed in the error message, I’m no expert, but here is the text from line 217 of the user.php file from the message above:

    $user = wp_get_current_user();

    Any help is greatly appreciated, as I use my site for my personal training clients and it’s been starting to affect my business, but GoDaddy are no help so far.

    Best Regards,
    Russ

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi

    (@esmi)

    Try re-uploading all files & folders – except the root wp-config.php & .htaccess files and the the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    russhowepti

    (@russhowepti)

    OK. I may sound dim here, but I have no idea what that is.

    When I installed wordpress, the only file I uploaded was called russhowepti.wordpress.2013-11-15…?

    Best regards,
    Russ

    esmi

    (@esmi)

    You can download a fresh copy of WordPress from http://wordpress.org/download/

    russhowepti

    (@russhowepti)

    Ah thanks. Will try doing this now 🙂

    russhowepti

    (@russhowepti)

    Sorry, didn’t work.

    Have re-installed the WordPress 3.7.1 zip file, but had no idea how to remove the files

    wp-config.php
    .htaccess
    wp-content

    esmi

    (@esmi)

    You do not want to remove those files or folders. Are you still seeing the same error?

    russhowepti

    (@russhowepti)

    Yeah, sadly.

    I re-installed WordPress, but just now the error popped up once again.

    esmi

    (@esmi)

    How exactly did you re-install?

    russhowepti

    (@russhowepti)

    I logged in to my website, it said I have the latest version of WordPress and I asked it to re-install..?

    esmi

    (@esmi)

    No – you need to re-upload all files & folders – except the root wp-config.php & .htaccess files and the the wp-content folder – manually from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    russhowepti

    (@russhowepti)

    Not sure how to do that.

    I have downloaded a copy of WordPress in a zip file.

    I can’t log into my blog at all, due to the error message.

    Hey there. I am also a GoDaddy customer and am having the same issue. I haven’t fixed it, but I can help you carry out a fresh install. To do so, go to your Godaddy account. Login. Then go to my products. Then “Launch” the hosting panel. From there, you should see applications somewhere on the page. Click on WordPress. Then choose your domain and account information. Then accept to overwrite the existing data. Then wait for it to finish. After that, log in to the site. Hover over “Tools” and choose import. Hopefully this should work. If it does, please let me know!

    This is either related or a coincidence, I too had this issue on the one and only Godaddy site I manage.
    Somehow (maybe my fault) when I installed wp it assigned my username as “admin” .. I’ve done hundreds of installs and always use the same username, never admin, but perhaps I forgot this time and it defaulted..
    Anyway, I changed my username with a plugin. Then when I would log in, I’d get a broken page (no css) but If I clicked a link it was the site as usual.

    This is exactly when I started getting the same error you describe.

    And wp-includes/user.php on line 217 is something like get_current_user.

    So I switched my user name back to admin yesterday and haven’t seen the error again, even after extensive work on the site.

    We had similar problem when we developed our firewall plugin (Centrora Security) for WordPress when we call the function ‘is_user_logged_in’ in the Ajax class, and find that this is related to the APC module for Apache, to resolve it, simply edit your php.ini to uncomment the apc module so it reads from

    extension=apc.so

    to

    ;extension=apc.so

    This will resolve the problem. Once we disable it, the error disappeared. Hope this helps. 😉

    I have been using wordpress for 2 months now. Only one website gives me this message.

    any idea how to fix? I tried restoring to an earlier date. did not work. I use godaddy.
    Fatal error: Function name must be a string in /home/content/07/7009007/html/BF/wp-includes/wp-db.php on line 1

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Fatal Error.’ is closed to new replies.