Support » Installing WordPress » Fatal Error?

  • When I run the wp-install script, I receive this:
    1. SQL/DB Error —
    2. [
    1. Error establishing a database connection!
    2. Are you sure you have the correct user/password?
    3. Are you sure that you have typed the correct hostname?
    4. Are you sure that the database server is running?
    ]
    1. SQL/DB Error —
    2. [
    1. Error selecting database db95628109!
    2. Are you sure it exists?
    3. Are you sure there is a valid database connection?
    ]
    Fatal error: Failed opening required ‘ABSPATHwp-includes/wp-db.php’ (include_path=’.:/usr/local/lib/php’) in /homepages/1/d94435456/htdocs/wp-settings.php on line 24
    I manually set up my DB on the host, and it automatically supplies the name, username and PW. I plugged them into the config script, as well as the db_host, which was explicitly specified when I built the DB. I tried switching that back to “localhost,” but it did no good.
    My config script is as follows:
    <?php
    /** WordPress’s config file **/
    // ** MySQL settings **
    define(‘DB_NAME’, ‘db95628109’); // The name of the database
    define(‘DB_USER’, ‘dbo95628109’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘<deleted>’); // …and password
    define(‘DB_HOST’, ‘db51.perfora.net’); // 99% chance you won’t need to change this value
    // Database tables’ names
    //
    // Change them if you want to have multiple blogs in a single database.
    // If you already have custom names leave table_prefix empty and just
    // edit the names.
    $table_prefix = ‘wp_’; // eg ‘wp_’ or ‘b2’ or ‘mylogin_’
    $tableposts = $table_prefix . ‘wp_db95628109_posts’;
    $tableusers = $table_prefix . ‘wp_db95628109_users’;
    $tablesettings = $table_prefix . ‘wp_db95628109_settings’; // only used during upgrade
    $tablecategories = $table_prefix . ‘wp_db95628109_categories’;
    $tablecomments = $table_prefix . ‘wp_db95628109_comments’;
    $tablelinks = $table_prefix . ‘wp_db95628109_links’;
    $tablelinkcategories = $table_prefix . ‘wp_db95628109_linkcategories’;
    $tableoptions = $table_prefix . ‘wp_db95628109_options’;
    $tableoptiontypes = $table_prefix . ‘wp_db95628109_optiontypes’;
    $tableoptionvalues = $table_prefix . ‘wp_db95628109_optionvalues’;
    $tableoptiongroups = $table_prefix . ‘wp_db95628109_optiongroups’;
    $tableoptiongroup_options = $table_prefix . ‘wp_db95628109_optiongroup_options’;
    // This is the name of the include directory. No “/” allowed.
    $b2inc = ‘b2-include’;
    /* Stop editing */
    $HTTP_HOST = getenv(‘HTTP_HOST’); /* domain name */
    $REMOTE_ADDR = getenv(‘REMOTE_ADDR’); /* visitor’s IP */
    $HTTP_USER_AGENT = getenv(‘HTTP_USER_AGENT’); /* visitor’s browser */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    $abspath = dirname(__FILE__).’/’;
    // pull in the day and month translations and the smilies
    require_once($abspath.’wp-config-extra.php’);
    require_once($abspath.$b2inc.’/wp-db.php’);
    require_once($abspath.$b2inc.’/b2functions.php’);
    require_once($abspath.’wp-settings.php’);
    ?>
    Is there anyone out there who can see any glaring errors and point me in the right direction?

Viewing 7 replies - 1 through 7 (of 7 total)
  • seagis,
    Is this a direct copy/paste from your file? I noticed this line:

    define(‘DB_PASSWORD’, ”); // …and password

    What about changing the double quote to a single quote?

    Which version of WP are you running? I see a lot of instances of “b2” in the code you pasted.

    It’s version 0.72, according to the top of the readme file. I’m going to download 1.0 and see if that doesn’t work a bit better for me if I can’t get this working soon.

    Oh, and by the way: The double quote you see is actually a set of two single quotes set together. Instead of leaving the PW showing, and forgetting that the comment box allows HTML, I typed the greater than\less than signs around the word ‘deleted.’ That’s why it shows up the way it does. My goof.

    OK. New problem.
    I went ahead and downloaded 1.0.1 since I hadn’t really done anything with the original version that I had. I wasn’t losing anything, I figured, so why not?
    Now I can run the install-config script and get this:
    Error establishing a database connection! This probably means that the connection information in youn wp-config.php file is incorrect. Double check it and try again.
    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    I went back to my web host and double checked the accuracy of the DB info, and it’s all correct. Any idea what’s missing?

    Is your user a member of the database? You have to specifically go into MySQL and add the user to the database.

    Hrmm… that’s a 1and1 database, and they automatically add the one user to the database when they set it up… my suggestion is to try getting phpMyAdmin working with your database info… If THAT doesn’t work (it’s really easy to set up, incidentally) then you might have to contact 1and1’s support.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal Error?’ is closed to new replies.