Support » Installing WordPress » fatal error

  • Following on from my ‘file permission failure’ post. I have temporarily set everything at 777 so I can now access my blog. But now, when I go into the admin section and click in themes I receive the following error

    Fatal error: Call to a member function on a non-object in /files/home3/andre02/wordpress/wp-includes/functions.php on line 1491

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mark (podz)


    Support Maven

    That’s a file upload error.
    Delete ‘functions.php’ and reupload
    If the error persists, or another appears, then delete all the files in the /wp-includes/ directory and reupload again.
    If that still does not cure it, you will probably need to change your ftp client. Filezilla is an excellent choice.

    Did not cure it. I can’t quite see what using another FTP client would do. CuteFTP seems to have sucessfully transfered the new files over. But I will try again later.

    Okay I have now tried Filezilla with no luck. Exactly same error message.

    Any ideas

    I have this very same error message. It started after I added several themes to the themes folder. 2 of the 10 themes that I downloaded caused this error to occur. Yes, just simply having these themes’ folders in the /wp-content/themes folder causes the Presentation tab to show the error you mentioned. So after having nailed it down to the two theme folders in particular, and having removed them now, the problem has gone away. I don’t think it’s necessarily the themes’ fault, however, since I tried another download of one of those themes, and it loads just fine. Weird! I did not have to go through changing of any file or directory permissions, by the way.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘fatal error’ is closed to new replies.