WordPress.org

Forums

Fatal error (6 posts)

  1. Guzzie
    Member
    Posted 10 years ago #

    I get this error when i run the installation file :
    Fatal error: Failed opening required '//wp-settings.php' (include_path='.:/usr/local/lib/php') in //wp-config.php on line 31
    I'm using wp version 1.2.1, PHP 4.3.0 , mysql Ver 11.18

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    This is a fault caused by the host's installation of PHP, the effect being to add the extra /
    You could ask them about it ? It's not a WP code issue.
    Sorry!

  3. jgds100
    Member
    Posted 10 years ago #

    I also get this error. glad to know the problem lies with my host's installation of PHP, not with WP.
    Could you give me details of the PHP installation issue - i.e. how sys admin might go around solving the problem. Or a bug number or something?
    Cheers

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    It's a path issue.
    The line in wp-config.php is this
    require_once(ABSPATH.'wp-settings.php');
    which should correctly translate with one 1 /
    I'd guess that they have something set which adds another / when it should not.
    If they say that other php files run so it can't be their mistake, they are wrong.
    Another site I run had this issue when the host changed their php version. I had to change scripts to make it run, then they changed it back, but my changes still allowed everything to run, and will do if they screw it up again.
    It's not a difficult change for them to make.

  5. easilyi
    Member
    Posted 10 years ago #

    Hi,
    Could you tell me how to see what the value of ABSPATH is?
    I installed a second worpress in a new directory and it is not working. The install worked, but index.php is blank. I can't figure out what the problem is, but this thread sounds like something I should check into. OH, the thing is, I am not getting any error, just a blank page.
    I acutally already contacted my host and they said it must be my script, so I want to get more info before I go back to them again.
    Thanks!!

  6. wendicity
    Member
    Posted 10 years ago #

    I know nothing about worpress, my husband set me up. He doesn't have time to help me. PLEASE! I can not log into wordpress. I was messing about in my vdeck. Yikes I have really messed things up. I don't know where to begin. Any help would be great! Thanks

    Fatal error: Call to undefined function: get_bloginfo() in /home/wendicit/public_html/blog/wp-includes/wp-db.php on line 304

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.