Support » Plugins » Fast Secure contact form

  • glreber


    I am having issues with the Fast Secure contact form. I host thru Godaddy and recently changed my hosting from windows deluxe to linux 4g. I had the plugin working previously but then after the switch the captcha image stop displaying. I then tried to uninstall and reinstall and now it get the following errors.

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/04/8260904/tmp/sess_hsradrqf1pme0rn46nscmftbd7, O_RDWR) failed: No such file or directory (2) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: session_start() [function.session-start]: Cannot send session cookie – headers already sent by (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-includes/pluggable.php on line 934

    Warning: Unknown: open(/var/chroot/home/content/04/8260904/tmp/sess_hsradrqf1pme0rn46nscmftbd7, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    I have contacted godaddy but they say it is not on the server side it is a plugin issue. Any suggestions would be appreciated. I saw a old post talking about this issue and being related to the php session temp location but again Godaddy said it is nothing on their side.


Viewing 15 replies - 1 through 15 (of 25 total)
  • hattendesign


    It is a Godaddy issue but they won’t help 🙁 -> This is usually the case with Godaddy.

    Here’s a quick fix..

    Create a new folder on your root directory and call it sessions
    Change its permissions to 777 (Check all the options from GD’s control panel viewable – writable – executable )

    At this point you should have a folder like

    open wp-config.php with your text/code editor and put


    for anyone else with the same problem just replace “04/8260904” with your GoDaddy user folders.

    For enhanced security put the folder inside your host’s root out of public view. (I’m not sure if the “web viewable” box in GoDaddy will help with this)

    You may want to change the name sessions to something unique too.




    I forgot to mention that the code should got on line 2 right below

     * The base configurations of the WordPress.
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     * @package WordPress



    thanks but i made the change as suggested and it still points to the same session folder (tmp) and has the same errors.



    What’s your url?



    I am actually trying something with Godaddy. I have changed my hosting plan to windows (w/php support) and then will be changing back to just linux servers again. I am thinking this will move me to another server that might not have the issues as when I originally started with them I had a windows/php supported account.

    Here is the link, it is a test site that i use to experiment with but it is hosted on the same as my other sites. thanks for the help.





    I see. You’re trying to access the plugin test file directly. The test gives an error because it doesn’t use wp-config.php

    The code I posted is a fix for the wordpress installation so any other php file which requires sessions would give out the same error.

    If you activate the plugin and use it within wordpress, it will work.

    To get rid of the error just add the same session_save_path code to the index.php in the captcha test.

    Looking into the form script, you’ll also need to add the same session_save_path() to secureimage.php

    Captcha uses sessions and the file tries to create a session on the path specified by the server.

    Ideally, you shouldn’t have to specify the save path but in your case (and the case of many) they don’t seem to change when you switch OS.



    thanks for the info I will keep this information. the package change with godaddy is now completed which moved me to another server and the plugin is now working as it did before. I am going to leave it on the windows based server for now (since it works) and maybe in the future change it back to pure linux.

    thanks again.



    thanks hattendesign I added the session_save_path(‘/home/content/04/8260904/html/sessions’); line with my user id and it fixed it.

    this post should be highlighted as I’m sure this impacts several Godaddy users. I had this on several websites after upgrading to 4GH. I guess it depends on the theme and plugin used but it fixed the issue.




    Yes thanks. As a follow up i had my sites migrated back to a different 4gh server and it does seem to be an issue with Godaddy’s server/php setup. The above solution works and I have implemented. There is also another plugin that is pretty good for anti spam on forms and comments. WP Enmask.

    Thanks again hattendesign.

    I just got this error when I set up a new blog (multisite). I DID switch servers a few weeks ago.

    All the other blogs work fine, it’s only a problem for NEW blogs.

    I disabled the plugin for now because I don’t have the time to do a bunch of coding every time wordpress upgrades and really don’t need the headache.

    What exactly is it that’s wrong with my new server and why does it only affect NEW blogs?

    Appreciate any suggestions,





    The reason for this error is that the default path to the session (tmp) folder is wrong or the folder does not exist.(or it’s not accessible by the user)

    You can break it down by looking at the error…

    WP is looking for a folder inside
    But your ROOT folder is actually

    adding a folder called ‘tmp’ to your root account would probably solve this issue however, you cannot go beyond the html folder. In this case, html is your root folder so, you need to create your own tmp or session folder and redirect the server to it.

    Again this is a fix to a specific issue when you switch from windows to linux on Godaddy.

    If you need help with your multisite setup send me a link to one that has the error and I can probably point out where the issue is.

    Thanks so much for your reply!

    I reactivated it so I could see the exact error, set up a new blog and it worked fine.

    So I’m guessing that it fixed itself, that somehow when I created the last new blog while it was deactivated a folder was created or “whatever.”

    FYI, I was on a linux server before, just moved to a new host (not GoDaddy).

    I just went to the plugin site and I’m so impressed. Installed the form several years ago and hadn’t looked at it since because it’s just been working trouble free. It’s amazing what all it can do.

    I just donated $10 and thanks for a plugin that works great and even comes with support!

    I was sure I posted here a couple days with the exact error I got when I tried to approve a comment. I was just going to update to say that the error went away again yesterday and everything still works just fine.

    I have done NOTHING to my WP installation and am not aware of any changes at my server. This is very strange.

    Another update:

    Did all sorts of work on blogs today without any problems until finally this evening I got the error again on all blogs except the main blog (multisite).

    Had my roomie check on his computer since he had also been working on the sites and he didn’t mention any problems. Everything was fine for him. So I restarted my machine and bingo!

    Very odd, but I’m glad it’s only ME getting the error and that restarting my computer fixes it.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Fast Secure contact form’ is closed to new replies.