Support » Plugin: FAQ Manager » FAQ's Appearing in Sidebar when Widget isn't Activated

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Andrew Norcross

    (@norcross)

    I can see the issue, the filter for displaying the items is also getting into the nav (which is shouldn’t). let me find a fix.

    Plugin Author Andrew Norcross

    (@norcross)

    Looking a bit closer, I’m not seeing where in the plugin itself that the query is being modified. Do you have something filtering the post content ( a pre_get_posts or similar ) to add FAQs?

    Plugin Author Andrew Norcross

    (@norcross)

    to clarify, the items being displayed on the sidebar are not from a widget, it’s the content inside a shortcode. so either someone put a shortcode in the nav (not likely) or its otherwise a modified query from the theme.

    Ok I will look into this more… thank you.

    What query do I need to look for?

    <?php
    /**
     * The Sidebar containing the main widget areas.
     *
     * @package Toolbox
     * @since Toolbox 0.1
     */
    ?>
    		<div class = "span3 page-sidebar">
    		<div class = "well">
    			<?php do_action( 'before_sidebar' ); ?>
    			<?php if ( ! dynamic_sidebar( 'sidebar-1' ) ) : ?>
    
    				<div class = "sidebar-box widget widget_search">
    					<?php get_search_form(); ?>
    				</div>
    
    				<div class = "sidebar-box widget">
    					<h3 class="widget-title"><?php _e( 'Archives', 'toolbox' ); ?></h3>
    					<ul>
    						<?php wp_get_archives( array( 'type' => 'monthly' ) ); ?>
    					</ul>
    				</div>
    
    				<div class = "sidebar-box widget">
    					<h3 class="widget-title"><?php _e( 'Meta', 'toolbox' ); ?></h1>
    					<ul>
    						<?php wp_register(); ?>
    						<aside><?php wp_loginout(); ?></aside>
    						<?php wp_meta(); ?>
    					</ul>
    				</div>
    
    			<?php endif;  ?> <!-- // end sidebar widget area -->
    		</div><!-- #secondary .widget-area -->
          </div>

    This is all the code for the sidebar says… and it doesn’t look out of order at all.

    Plugin Author Andrew Norcross

    (@norcross)

    it’s a widget that is displaying the items on the side, or something hooked into your do_action( 'before_sidebar' ); action.

    did you build the site or did a developer handle it?

    I inherited this site from two developers before me. I have reactivated a plugin called “Contextual Widget” and it got rid of it. But what I’m not sure how in the world its working, because there wasn’t a physical (still isn’t) widget that it’s calling on the side bar. We are only calling Custom Menus and I went through them each to make sure someone hadn’t put some funky code in it.

    My supervisor wants to just move on but if someone deactivates that plugin the problem will reappear again..

    Where do I find this do_action?

    Thanks,
    Megan

    Plugin Author Andrew Norcross

    (@norcross)

    custom menus can be used as widgets, which is what I imagine is happening here. without seeing the scope of the code (which is beyond the level of help I can provide here) there is something that is modifying the loop that those menus are being generated from.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘FAQ's Appearing in Sidebar when Widget isn't Activated’ is closed to new replies.