Support » Plugin: Schema & Structured Data for WP & AMP » FAQ schema type apparently triggering redirects

Viewing 6 replies - 1 through 6 (of 6 total)
  • How To schema option also triggers redirect problem

    Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Can you help us more in this? Have you tried disabling our plugin and save the post?

    It appears that disabling the plugin and saving the post might have cleared the issue. this could have been an issue with caching – but I had cleared and tried many many times and enabled/disabled and played with schemas.

    But in attempting to systematically test and recreate the error — a dozen different combinations of schema enabled/disabled etc…

    there currently are no errors…

    so maybe the simple solution worked.

    Thanks

    it’s very possible that attempting to use fields in the modify schema section ran into conflicts and triggered the redirects – that is the most likely scenario – for now I don’t have time to test that.

    Plugin Author Magazine3

    (@magazine3)

    I’m sorry to hear that, but inorder to fix it, we need to re-create this and understand the problem.

    I would love some input from you or anyone else who is willing to work with me to fix this issue.

    Hi – thanks for following up on this.

    RECAP: WP multisite, SSDWPAMP activated per subsite, Custom post type (directory), other schema generated by theme and CTP plugin. also Advanced Custom Fields Pro plugin activated. WP Super Cache and Autoptimize. Cloudflare Full strict encryption (tried with full and flexible, still got errors)

    my problems are persisting – when saving post with FAQ enabled it triggers redirect error and 520 crash from cloudflare. have tried disabling plugin and saving and clearing caches etc.

    I think this is related to caching but really can’t say. my host guesses that plugin is calling insecure asset. I have tried this with quite literally 40 different attempts to see what combination triggers – trying to clear caches, enabling/disabling plugin, saving post, etc each time

    The schema from other sources are:
    Webpage
    Organization
    BlogPosting

    Activating SSDWPAMP
    (settings > advanced > MicroData CleanUp checked — note tried with this checked, not checked and does not affect error trigger)
    Schema gets generated behind the schenes
    Interaction Counter
    Person (this is actually desirable and links to buddypress author profile)

    TouristAttraction does not trigger errors
    HowTo schema on refreshed post (plugin enabled/disabled, caches etc) does not trigger errors

    FAQ triggers redirect cloudflare 520 error

    so, if i delete FAQ schema type and create a new one LocalBusiness – and save – it triggers error. delete LocalBusiness and save post with TouristAttraction and HowTo enabled… no error…

    disable plugin, create LocalBusiness and save… triggers error

    so… FAQ, LocalBusiness with this setup … are hitting redirect errors

    probably some simple thing somewhere… but I have no clue

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.