Support » Plugin: Restricted Site Access » FAQ code gives syntax error and doesn’t look like there’s support here?

  • rileyadamvoth

    (@rileyadamvoth)


    When I use the php given in the FAQ section here for unblocking an RSS feed I’m given an error: syntax error, unexpected ‘feed’ (T_STRING)

    Is this a common problem and is there any guess as to how I can fix it? I’ve tried many things but can’t make it work. Am I missing something obvious?

    I’ll probably just have to find a different plugin though cause it looks like there are dozens and dozens of support questions on this plugin that go unanswered here so I’m guessing this isn’t really a supported plugin. Right?

Viewing 1 replies (of 1 total)
  • williampatton

    (@williampatton)

    Hey @rileyadamvoth

    This plugin is supported 🙂

    So the issue you are seeing sounds to me like it might be caused by the inverted commas around the word feed being missing.

    function my_rsa_feed_override( $is_restricted, $wp ) {
        // check query variables to see if this is the feed
        if ( ! empty( $wp->query_vars['feed'] ) ) {
            $is_restricted = false;
        }
        return $is_restricted;
    }
    add_filter( 'restricted_site_access_is_restricted', 'my_rsa_feed_override’, 10, 2 );

    Does the code inside your function look exactly like that? With the single inverted commas around the word feed?

Viewing 1 replies (of 1 total)
  • The topic ‘FAQ code gives syntax error and doesn’t look like there’s support here?’ is closed to new replies.