Support » Theme: Customizr » Fancybox version conflict with plugin

  • Dan Tappan

    (@dantappangmailcom)


    I have been using Customizr for several years. I have donated toward it’s support.

    I just tried installing a new plugin – the “WP Lightbox Ultimate” and found that parts of it didn’t work properly under Customizr. Apparently there is a version conflict between the version of Fancybox that Customizr installs (1.3.4) and the version required by the plugin (version 2.x.x).
    According to the Fancybox website version 2 is the latest version, version 1.3.4 is quite old.

    Are there any chance of Customizr being upgraded to use & install the latest version of Fancybox?

    Failing that, is there any way to force loading of the newer Fancybox? And if I do, will it break Customizr?

    Seems to me that releasing incompatible libraries with the same name is a pretty severe issue with Fancybox, but that’s their issue, not yours.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Dan,
    you can disable theme’s lightbox effect.
    Please see:
    http://docs.presscustomizr.com/article/149-a-button-stopped-working-on-my-website
    (different problem but same solution).

    Hope this helps.

    Dan Tappan

    (@dantappangmailcom)

    Thank you for the suggestion. That does fix the problem. I can live with using the plugin for photo lightboxes instead of the Customizr feature.

    Glad to see you solved.
    Would you mind marking this topic as resolved?

    Many thanks.

    Cheers

    Dan Tappan

    (@dantappangmailcom)

    Is there a way to mark it “kinda resolved”? As a long term fix it would be nice if the library conflict weren’t there at all. I would have liked to use the Customizr lightbox based gallery, but with this workaround I can’t.

    Dan Tappan

    (@dantappangmailcom)

    BTW: I had used some CSS to change my main page slider transition from a “Slide” to “Fade” (IMO the slide looks kind of jarring and ugly). And it turns out that when I turned off Customizr Lightbox as above this broke and I’m back to a slide.

    So it would be really nice to have a way to resolve this Fancybox conflict so I could get the effects working everywhere.

    Dan Tappan

    (@dantappangmailcom)

    Any prognosis on this? it’s really a shame Customizr isn’t compatible with up-to-date Fancybox effects.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fancybox version conflict with plugin’ is closed to new replies.