Support » Plugin: NextGEN Gallery Optimizer » Fancybox Setting / Picture in Article

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mark Jeldi


    Hey Fritz,

    I’ve been testing your source, and it appears this may be another issue with your theme. It seems to be adding several <br /> line breaks at the end of each line in NextGEN’s HTML output. When I remove these manually, your formatting displays as it should.

    I’ve had a look in your theme’s functions.php file (which was responsible for the title-stripping issue last time), but to no avail, I’m afraid. However, you might like to try opening up your singlepic template at wp-content/plugins/nextgen-gallery/view/singlepic.php, and put the entire anchor tag structure on one line. Eg…

    <a href="<?php echo $image->imageURL ?>" title="<?php echo $image->linktitle ?>" <?php echo $image->thumbcode ?> ><img class="<?php echo $image->classname ?>" src="<?php echo $image->thumbnailURL ?>" alt="<?php echo $image->alttext ?>" title="<?php echo $image->alttext ?>" /></a>

    Doing this removed the first two line breaks for me on my dev site, and if you also start your text immediately after the shortcode in your post editor, may remove the third also.

    Hope this helps!


    hey mark, thank so much!

    unfortunately there ist already this code in the singlepic.php

    or am i wrong?

    thx so much 🙂

    <?php if (!defined (‘ABSPATH’)) die (‘No direct access allowed’); ?><?php if (!empty ($image)) : ?>
    imageURL ?>” title=”<?php echo $image->linktitle ?>” <?php echo $image->thumbcode ?> >
    <img class=”<?php echo $image->classname ?>” src=”<?php echo $image->thumbnailURL ?>” alt=”<?php echo $image->alttext ?>” title=”<?php echo $image->alttext ?>” />

    <?php if (!empty ($image->caption)) : ?><span><?php echo $image->caption ?></span><?php endif; ?>
    <?php endif; ?>

    uhmmm mark, you are my men! 🙂 goot it right now, the secret was the “one line”

    thx so much again!

    Plugin Author Mark Jeldi


    Hey Fritz,

    No worries. I’m glad that helped. It’s looking much better! 🙂

    All the best as always,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fancybox Setting / Picture in Article’ is closed to new replies.