Support » Fixing WordPress » Fancybox / jquery not working since 3.0 upgrade

  • Im using fancybox into my blog, and since i upgraded to 3.0 it doesnt seems work al all, i use it to pop up image galleries and now it only redirects me to the image i click without any pop up, the script is palced at the header and uses jquery to work ( v1.4 i think )

    I tried deactivating all plugins but it doesnt seem to do any difference, also change to the default theme with no results, this is my site:


Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having the same problem. It appears to be related to the “#gallery-1 img” style which was previously hard-coded into the WordPress gallery. Fancybox and other lightbox plugins rely on this style to apply the jquery effects.

    I’m looking for a workaround that won’t break after the next update.

    Just a follow up. For testing, I installed Fancybox on a fresh WordPress 3.0 (not upgraded from previous version) and it works fine. Anyone have any suggestions why this might be occurring on upgraded WordPress sites?



    I redownlaoded the header file from my current theme and re-edited to include the fancybox addon, and now it works again… it seems that the upgrade messed somehow with my header file.. i still dont uderstand how…

    One last follow up:

    I’ve been banging my head against the wall for weeks trying to determine what was breaking not only my front page slideshow, but also the Fancybox (lightbox) gallery plugin. After disabling and reactivating various plugins in countless combinations, I finally isolated cForms II (v 11.5) as the cause.

    More specifically, the “Global Settings -> Popup Date Picker” was enabled. As soon as I disabled this setting, the jquery conflict disappeared and everything went back to normal. Unfortunately, I can’t use the popup date picker in forms anymore.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fancybox / jquery not working since 3.0 upgrade’ is closed to new replies.