Support » Fixing WordPress » Familiar with Apache2 userdir on WinDoze?

  • Resolved Beel


    Wondering if anyone has a clue how to “fix” this… I set up a userdir to run a test site. Works great until I try to set up permalinks and then the “root” is not in the userdir. So src=”/image.jpg” is not in mysite/~userdir but in mysite/ – hope that makes sense!

    Surely there is something I am missing that will keep users in their own directory.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Make sure your wordpress options are correctly configured. If you have the main index called from another folder other than wordpress, make sure you have your .htaccess file wherever your main index is.

    Thanks omann0, but I suspect all the WP options are set correctly – it is something I need to do in Apache’s config file – if I can at all.

    The WP index is in the user’s root directory and the permalinks all work fine for delivery of pages, etc., but the images all have to be set to “/~userdir/wp-content/image.jpg” instead of “/wp-content/image.jpg”

    This, of course would be fine, just add “/~userdir” to all the tags, but I would have to change them ALL back once the site goes live somewhere else…

    I bet someone who knows rewrite rules could come up with something simple to redirect for images. 😉

    Have you tried using the <base> tag in the <head> of your template?

    Doh! Of course a base tag would work. I was busy cookin’ in the kitchen, but my head was somewhere else. I would just have to remove the tag before uploading the installation.

    Thanks for redirecting me from permalinks and htaccess 🙂

    Any day I can provide an easy way out of a problem is a successful one.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Familiar with Apache2 userdir on WinDoze?’ is closed to new replies.