Support » Plugin: Force Strong Passwords » False Error on WP 4.3

  • Resolved FrancescoCarlucci

    (@francescocarlucci)


    Hi there,

    after WP 4.3 upgrade, I get this error when I add a user with Author/Editor/Admin or custom role:

    “ERROR: Please make the password a medium or strong one”

    Even if the password is strong!

    I contacted my hosting support (WP Engine) who confirmed is a plugin bug affecting non-English WP install.

    Hope you can help 🙂

    Cheers

    https://wordpress.org/plugins/force-strong-passwords/

Viewing 4 replies - 1 through 4 (of 4 total)
  • We’ve been having the same issue, and I discovered that the issue seems to stem from WordPress 4.3 having added the text domain ‘password strength’ to the translation of the words “Strong”, “Medium”, etc.

    https://github.com/WordPress/WordPress/commit/153511f78fb7bee90b511689af0091526879745a#diff-39977d20425ebfb23f09eb9d22eb7f0c

    Force Strong Passwords hasn’t yet updated from the old version where those phrases didn’t have a text domain.

    We also have our hosting on WP Engine, so I’ve written to them to see if they can add a patch to their mu-plugins before the official plugin gets fixed.

    Yes a patch would be absolutely appreciated!! 🙂

    In the while I have disabled the plugin, I post the code if it can be useful:

    add_action('init', function() {
    remove_action( 'admin_enqueue_scripts', 'slt_fsp_enqueue_force_zxcvbn_script' );
    remove_action( 'login_enqueue_scripts', 'slt_fsp_enqueue_force_zxcvbn_script' );
    remove_action( 'user_profile_update_errors', 'slt_fsp_validate_profile_update', 0, 3 );
    remove_action( 'validate_password_reset', 'slt_fsp_validate_strong_password', 10, 2 );
    });
    Plugin Author Jason Cosper

    (@boogah)

    Version 1.6 (released just a few minutes ago) addresses this issue. It’ll take several days before WP Engine can roll the new version out, however.

    In the interim, you can either disable the plugin the code that Francesco supplied or ask WP Engine support to drop a copy of 1.6 over the top of your current version.

    Thanks boogah 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘False Error on WP 4.3’ is closed to new replies.