• Resolved lbaccess

    (@lbaccess)


    I’m seeing a number of “Image Empty Alternative Text” warnings with this plugin. A couple of cases were for logos in the global footer. The referenced code in the warning said that alt=””, but all the images in our site’s Media Library have alt tag information. The plugin doesn’t seem to be picking those up. Is this a bug, or is there a secondary place I have to enter them? Latest versions of WP and plugin installed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Steve Jones

    (@stevejonesdev)

    Hi @lbaccess, Have you confirmed that your theme is outputting the entered alternative text? You can view the page source or use the browser inspector to check that the images are outputting the alt text.

    Thread Starter lbaccess

    (@lbaccess)

    Hi Steve, you were right, the images in the footer were not outputting the alt tag, even though I have specified them in Media Library. (They say, alt=””.)

    I went to the footer section in Widgets and selected the images in question. They had blank alt fields. I filled them in and cleared the theme cache. Inspecting the images in the browser, the alt tags are now being output.

    However, hours after, the Image Empty Alternative Text warnings persist. Any ideas?

    Plugin Contributor Amber Hinds

    (@alh0319)

    Hi @lbaccess,

    If you have the Pro version of Accessibility Checker, you can run a new full site scan to rescan the site and clear those errors from every page and post sitewide.

    If you’re using the free version of the plugin it only scans on post save, so you would need to open each post and page and hit update. This would trigger it to rescan the page and the empty alt warnings should then go away.

    Thread Starter lbaccess

    (@lbaccess)

    Thanks Amber, that did the trick.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.