Support » Plugin: Wordfence Security - Firewall & Malware Scan » Falcon not working

  • Resolved John Conner

    (@johnconner)


    Wordfence is a great security plugin itself, but as Falcon was added I tried it on some WP websites. Unfortunately, Falcon and/or Basic cache creates static files just for homepage. Falcon option was enabled, htaccess rules were written, checked on root and subfolder and subdomain WP installations. Hope it’ll get improved 😉

    https://wordpress.org/plugins/wordfence/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WFMattR

    (@wfmattr)

    Are there any common plugins (or a particular theme) across the sites where it is not working? It’s still working on our test servers, so there may be something else affecting it.

    If you are able to temporarily disable other plugins on one of the sites and switch to a default theme like “twentyfifteen”, you can check if the other pages are cached properly then.

    It might also be possible that your host offers caching outside of WordPress — if you have Varnish or nginx configured as a reverse proxy (or if you use CLoudFlare), the cached pages in those services may be served before it reaches your actual site.

    If this does not help, are all of the sites on the same server? Or at the same hosting company?

    -Matt R

    Hi Matt,
    Really appreciate for clues. I have WP installations on VPS (nginx and litespeed) and hostinger shared plan. CF is not used, and disabling other plugins wasn’t helpful. I really like Wordfence, and I’ll spend time to find out the reason, actually I suspect some rules in htaccess. Please keep falcon free, until I could reach a conclusion 😉

    Plugin Author WFMattR

    (@wfmattr)

    Ok, thanks for the reply — we don’t have as many users using Falcon on nginx or LiteSpeed, so there could be some issues with certain configurations that we haven’t seen yet.

    For the nginx server, have you seen this document yet? Some additional setup is necessary for running Falcon on nginx with PHP5-FPM:
    Nginx.conf rules for Wordfence Falcon Engine Caching when using Nginx and PHP5-FPM

    Falcon should normally work on LiteSpeed, but it’s possible something has changed. I know that a few things that are allowed in .htaccess don’t work quite the same as they do in Apache.

    As an aside, LiteSpeed does need a change in .htaccess to prevent the web server from aborting longer-running processes. You might have already set your server up this way, since it would usually be necessary for Wordfence scans to work, and some other plugins, especially backup plugins:
    Litespeed aborts Wordfence scans and updates. How do I prevent that?

    (I don’t think this would change Falcon’s operation, in saving cached pages.)

    -Matt R

    I’ve tested falcon in different situation, to force it work.

    – Falcon is not ready-to-use for Nginx, but works fine with litespeed and apache.
    – It works fine with default root-installed direct-domain-access website which its WP installation is intact.
    – Customization is not easy.
    – Although Falcon has no issue with subdomain installations, it works so-so.
    – Falcon is not easy-to-use for folder installations (example.com/wp/), mostly doesn’t work.

    Based on results, actually I prefer to use my previous cache plugin, and keep WF as security one.

    Plugin Author WFMattR

    (@wfmattr)

    Thanks for the feedback — we do have some nginx servers with falcon running, with the nginx.conf changes mentioned above, and also some WP sites installed in a subdirectory that are working for us — but both setups are less common among our users, so we may not hear about some of the possible issues on different hosts. If you noticed any specific items that were not working well, we can take a look, if you want.

    Thanks!

    -Matt R

    Just found an issue: Falcon presume its cache folder inside “wp-content”, and if the content folder’s name be changed it wouldn’t work properly.

    Edit: changing “wp-content” in WF options and htaccess didn’t help.

    Plugin Author WFMattR

    (@wfmattr)

    Thanks, I’ve mentioned this to the dev team to check out.

    -Matt R

    Testing with WF Falcon, but running into issues of pages creating a constant loop.

    I’m using a subdomain installation.

    Plugin Author WFMattR

    (@wfmattr)

    @h.a.visser: Thanks for the report — since this may be a different issue, please make a new post using the form at the bottom of the Wordfence forum here.

    Please include any other details if you can, including whether this is on domain-mapped multisite (since you said it is a subdomain installation), or if it is just a single site on a subdomain.

    The wordpress.org forum rules also ask us to keep posts separate for each person, and it also helps us make sure each one will be seen. Thanks!

    -Matt R

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Falcon not working’ is closed to new replies.