Support » Plugin: Wordfence Security - Firewall & Malware Scan » Falcon Engine does not work without trailing slash.

  • Resolved oolleegg55

    (@oolleegg55)


    Hello!

    I tried to run Wordfence Falcon Engine. It works really quickly. But it has some issue.
    If “Permalink Settings” set as “Custom Structure” and parameter is “/%category%/%postname%” (exactly without trailing slash) cache does not work. Only home page is cached.

    I install default WP for tests. Then I set permalinks “/%category%/%postname%/” (with trailing slash). After this setup caching works great. If I remove trailing slash (“/%category%/%postname%”) it will not work (caching works only for home page).

    Can you help me? Where can I find error? What might it be?

    Thanks!

    https://wordpress.org/plugins/wordfence/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi oolleegg55,
    I confirm that the caching script was written to cache only pages end with trailing slash, your permalinks settings should have this slash by default, however, we have a similar request to support pages with no trailing slash in their URL’s (reference number: FB580), I will make sure to add your vote to this request.

    Thanks.

    Thread Starter oolleegg55

    (@oolleegg55)

    Hi wfalaa,
    I understood, thanks for answer!

    Hello!

    The strange behavior of the caching system.
    This problem has been known for more than one year:
    https://wordpress.org/support/topic/caching-urls-without-trailing-slash-nginx/

    Many people use the links without the end slash. Please make Falcon flexible. This is a very fast system based on nginx, many will install your product for that stack.

    Where can I read about FB580?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Falcon Engine does not work without trailing slash.’ is closed to new replies.