Wordfence Security
[resolved] Falcon Engine and WPTouch (7 posts)

  1. billrodgers2013
    Posted 1 year ago #

    The Falcon Engine sounds promising. Great work.
    I enabled it but had issues with WPTouch I use for mobile devices. WPTouch was all over the place.
    With other caches I've used on other sites with WPTouch I can exclude mobile user agents from using the cache. I pass them through and then on to Infinity Cache which comes with the Pro version of WPTouch.

    Any chance of having the same user agent exclusions with the Falcon Engine?


  2. Wordfence
    Plugin Author

    Posted 1 year ago #

    Yes we can definitely implement this. I've taken note of your comments and we'll get right on it.



  3. billrodgers2013
    Posted 1 year ago #

    Thanks for that. Can't wait t try it out.

  4. dmkjr
    Posted 1 year ago #

    I am to having this issue. Could you please let us know on this thread once it is fixed? I'm sure we could look at the release notes, but this would be a faster notification I think.

    Hyper Cache had this enabled as well, but WordFence seems to be a much better product.

    Thanks for your work.

  5. Lubyg
    Posted 1 year ago #

    I'm using an older version of WP Touch Pro. The desktop site is showing the Mobile view. This seems to happen with all cache plugins including Falcon Engine. We've moved as many sites as I can to Responsive Design rather than using WP Touch Pro but we have hundreds of sites.

    Any chance that will ever get addressed? I really like Wordfence!

  6. Adrian
    Posted 1 year ago #

    I'm also having this issue.
    Mobile users were seeing the cached desktop page (which didn't include the option to display the mobile version)..
    And if a mobile user had been the first to visit a page, a desktop user who then visited it would see the cached WPTouch version of the page.

    I decided I would have to disable Wordfence caching till a solution was delivered.

    But then I found the following bypass setting would work:

    If the User-Agent contains (without quotes): "iPhone" then don't cache it.

    It looks like this would work for mobile devices (smartphones) in general:
    If the User-Agent contains (without quotes): "Mobile" then don't cache it.

    I'm fairly sure this is a recent problem, perhaps caused by a recent change to WPTouch or Wordfence.

    It would be good if there were a way to cache the mobile pages as well.

  7. Lubyg
    Posted 1 year ago #

    Hi Adrian,
    It is likely ALL Caching Plugins, even those that allow for not caching for mobile devices and those that even have a WP Touch exception. Can't recall which one has that. We have tried the following with the same results:
    W3 Total Cache
    WP Super Cache
    Quick Cache
    Falcon Engine with Wordfence

    If you are only dealing with one website then you can monitor it if you are visiting your site daily. If you are like us with hundreds of websites then I advise NOT using any cache with WP Touch Pro or Jetpack Mobile. We've seen it happen with both those mobile plugins and we don't have time for more in depth testing.

    As time goes on we will be replacing all designs with

    Responsive Designs
    . That way there is no issue with Caching. Right now DIVI from Elegant Themes is our favorite responsive design. Of course, we can now customize our own themes. If you're looking for a good one then I'd try DIVI.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wordfence Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic