WordPress.org

Support

Support » Miscellaneous » Failure to upload image

Failure to upload image

  • I am experiencing difficulty to upload an image from my PC to a static page.I use WordPress version 2.91. Here is what I did:
    At the ‘From Computer’ tab, I browsed my images and select the image I want to upload > Open > Upload.
    I do not see the image, but only the borders of the would-be image. The text are correctly wrapped. Eventhough I do not see the image, the icon at the top left of the borders tells me the image name correctly.
    After alignment and size, I click on ‘Insert into Post’, Update and refresh my page.
    The front end shows a perfect space with text correctly aligned, but I do not see the image.
    I tried using both the Browser Uploader and Flash Uploader. Both failed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Does your picture has a defined format on your computer, namely jpg, jpeg etc.? Either way try changing the format to jpeg and see if it works

    Also make sure there are no spaces in the image file path. Sometimes images will be named “mike 332.jpg” or some silly thing and it may need to have an underscore instead. Apache will choke on a browser request that has a space in it I am fairly sure.

    I have tried both gomezu 111 and racer x’s suggestions and failed.

    My picture has a defined .jpg format.If I were to name my picure as xxxx.jpeg, it will show up as xxxx.jpeg.jpg

    I also made sure there is no space in the name.

    I read somewhere that WP versions later than 2.7 has some problem on image uploading. Do you deem it advisable to downgrade? Is there a version of WP that is totally reliable even though outdated, and if so, how do I get that?

    Suggestions to solve from problem on 2.91 is still welcomed.

    I downgraded to version 2.86 and solved my problems

    Hello!

    I have troubles when uploading a picture from my computer.
    I have received this message:
    Unable to create directory /home/watchoni/subdomains/blog/wp-content/uploads/2010/02. Is its parent directory writable by the server?

    Can anyone help?

    Tanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Failure to upload image’ is closed to new replies.