Support » Fixing WordPress » Failure to Upload Header Image

  • I recently lost several capabilities when I moved my website (twenty eleven) from my Word Press folder to my root folder at Go Daddy. I regained most of them by shifting from the Windows to the Linux platform. However, I still cannot upload an image from my desktop to the header of my website.

    When I try to do so, going from the header page on the dashboard, the box where you can crop the image before final upload appears, but there is no image in it, only a question mark against a blue background. I’m using an image that I was able to upload with no problems earlier. The default images upload with no problem, which led my last Go Daddy agent to say this was a Word Press issue. Any ideas on how to proceed?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi hrowland,

    Have you checked the permissions for your WordPress folders? Make sure your folders are set to 755:

    Hope this helps!

    Hi Christi,

    I’ll look into this. Thanks!

    Hi hrowland,

    Were you able to check your file permissions? Just wanted to check in and see if that resolved the issue for you.


    Hi Christi,

    Busy day today. I wasn’t able to check my file permissions, even with the help of the agent at Go Daddy. He said they don’t use numbers like 755 as such. What they have in permission files, such as “read,” “write,” etc., correspond to such numbers, but he was unable to find his “cheat sheet” that shows the correspondences. Strange. In my wp-content folder, “write” wasn’t checked, but he said if I hadn’t fooled with the settings, and I hadn’t, then the defaults should be accurate. I mentioned that another agent told me that strange things can happen during the transition from a wordpress folder to the root folder, thinking that maybe an “unchecking” was one of them, but he didn’t think so. I could experiment, but at his suggestion I tried to upload a different image, and it worked. That suggests that something was wrong with the image I was trying to upload, but it’s the one that was in the header up to the point of the shift to my root folder, and I tried another version of it just now, still with no success, so I still don’t know what’s going on.

    Thanks for checking up!

    Hi hrowland,

    755 corresponds to:

    user group world
    r+w+x r+x r+x

    r = read
    w = write
    x = execute

    So, your account (user) should have read, write & execute permissions. Group and world (may be called public in some FTP programs) should have read and execute permissions. This should apply to all of your WordPress folders.

    You can also use an FTP program to check this yourself if your hosting company has any issues translating the numerical values. You may want to double check with them as well to see if your need to have a different permissions scheme on their servers than the WordPress default.

    Hope this helps!

    Thanks, Christi. I’ll pursue this further.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Failure to Upload Header Image’ is closed to new replies.