WordPress.org

Support

Support » Plugins and Hacks » Force Regenerate Thumbnails » [Resolved] Failure to Regenerate Thumnails

[Resolved] Failure to Regenerate Thumnails

  • Nevis-1

    @nevis-1

    This is the message I received

    All done! 802 image(s) were successfully resized in 6236 seconds and there were 4777 failure(s). To try regenerating the failed images again, click here.

    Please be patient while the thumbnails are regenerated. This can take a while if your server is slow (inexpensive hosting) or if you have many images. Do not navigate away from this page until this script is done or the thumbnails will not be resized. You will be notified via this page when the regenerating is completed.
    100%

    Debugging Information

    Total Images: 5579
    Images Resized: 802
    Resize Failures: 4777

    Here is the error message

    function (){if(l){var t=l.length;(function i(t){x.each(t,function(t,n){var r=x.type(n);”function”===r?e.unique&&p.has(n)||l.push(n):n&&n.length&&”string”!==r&&i(n)})})(arguments),n?o=l.length:r&&(s=t,c(r))}return this}

    http://wordpress.org/plugins/force-regenerate-thumbnails/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Pedro Elsner

    @pedro-elsner

    Hi @nevis-1
    Please, try the new 1.6 version

    Plugin Author Pedro Elsner

    @pedro-elsner

    Hello @nevis-1
    The some issue has been solved with new 1.7 version.
    Please, try and feedback me

    Hi,

    I’m having this same problem, even after upgrading to 1.7.

    I’m halfway through resizing the thumbnails on a client’s site now. First 350 or so were successful, and the rest (5,400 and counting) have failed with the same error as above. Any idea?

    function () {if(l){var t=l.length;(function i(t){x.each(t,function(t,n){var r=x.type(n);"function"===r?e.unique&&p.has(n)||l.push(n):n&&n.length&&"string"!==r&&i(n)})})(arguments),n?o=l.length:r&&(s=t,c(r))}return this;}
    Plugin Author Pedro Elsner

    @pedro-elsner

    @fishbucket your website running above windows or linux plataform?

    Linux

    Plugin Author Pedro Elsner

    @pedro-elsner

    @fishbucket, please, try new 1.8 version

    Hi,

    I have always loved this plugin. I think it should be a part of WordPress Core. Thank you for it.

    Till now it has always worked for me.
    I created a new install and used this plugin in latest version 2.0:
    OS: Windows 8.1
    Server: WAMP
    Wordpress: 3.8

    I get the error “The originally uploaded image file cannot be found at “
    and if I output the $image_fullpath variable, it says:
    function (){if(l){var t=l.length;(function i(t){x.each(t,function(t,n){var r=x.type(n);”function”===r?e.unique&&p.has(n)||l.push(n):n&&n.length&&”string”!==r&&i(n)})})(arguments),n?o=l.length:r&&(s=t,c(r))}return this}

    Can you please help?

    Thanks

    I’m having the same problem since upgrading to 2.0:

    “The originally uploaded image file cannot be found at ””

    … for all images in my media gallery when I do a full force regenerate.

    Also, I tried reverting to 1.5 and all thumbnails regenerate properly, so it’s definitely a recent change causing problems.

    I’m also on Win7 x64, WAMP/IIS, WordPress 3.8.

    Plugin Author Pedro Elsner

    @pedro-elsner

    Right!
    @nickbouton and @teacii: What is your PHP version?

    PHP 5.4.12 (cli) (built: Feb 25 2013 00:29:22)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans

    Hey Pedro,

    Thank you for answering. My PHP is version 5.3.13

    A very happy new year to everyone.

    I had a similar problem and found this code in function ajax_process_image() to be the source:

    if ((strrpos($image_fullpath, get_option('upload_path')) === false)) {
    	$image_fullpath = realpath(get_option('upload_path') . DIRECTORY_SEPARATOR . $image_fullpath);
    }

    The upload_path option was removed in WP v3.5; see this support topic:

    WordPress 3.5 > where the option settings->media->upload_path gone !?

    I commented out the above code and everything worked fine on my site. I am using the “normal” month- and year-based folders. Other sites with custom upload directory schemes may need a different fix.

    Plugin Author Pedro Elsner

    @pedro-elsner

    Nice @DavidLingren
    I will fix it on version 2.0.1 with:

    if(get_option('upload_path')=='wp-content/uploads' || get_option('upload_path')==null) {
    update_option('upload_path',WP_CONTENT_DIR.'/uploads');
    }

    Thank you!

    Happy to help, of course. The WordPress Codex documentation for get_option says:

    A safe way of getting values for a named option from the options database table. If the desired option does not exist, or no value is associated with it, FALSE will be returned.

    Comparing the returned value to NULL may not do what you want.

    Instead of directly using/updating the deprecated option, consider using the wp_upload_dir() function instead:

    Function Reference/wp upload dir

    That would give you some protection from future changes and non-standard directory schemes.

    Plugin Author Pedro Elsner

    @pedro-elsner

    @DavidLingren, @teacii and @nickbouton,
    please, try new 2.0.1 version

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Failure to Regenerate Thumnails’ is closed to new replies.
Skip to toolbar