WordPress.org

Forums

Failure to open stream/Fatal Error (4 posts)

  1. whisperzone
    Member
    Posted 10 years ago #

    I've seen a few posts with this error, and tried all the recommendations without success.

    When I originally uploaded the files into the blog subdirectory, no /blog/wp-admin directory was created in the unzipping process. Running install got the "There doesn't seem to be a wp-config.php file" message.

    So I created one and copied all the files in there, too. Now I get

    Warning: main(/home/whisperz/public_html/blog/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/whisperz/public_html/blog/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/whisperz/public_html/blog/wp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /home/whisperz/public_html/blog/wp-settings.php on line 39

    As I said, I tried all the recommended fixes, including playing with different ABSPATH paths. Nothing seems to work.

    Anyone got any ideas what to try next?

  2. Kafkaesqui

    Posted 10 years ago #

    Is there a /wp-includes/ directory? Does the file wp-db.php reside in there?

    You may want to try reuploading the full installation.

  3. whisperzone
    Member
    Posted 10 years ago #

    No, there isn't. Were those sub-directories to have been created automatically?

    I'll try it again tomorrow.

  4. whisperzone
    Member
    Posted 10 years ago #

    I've tried downloading ver 1.5 several times without success in having any subdirectories created when unzipped. Is there documentation on setting them up manually, and what should go in each?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.