Support » Plugin: WordPress Importer » "Failure to import" and "Invalid post type" errors

  • Sorry to add yet another question with a similar topic, but this is beginning to drive me mad, and none of the other resolved topics for this problem seem to apply to me.

    I have developed a blog on my localhost server which is running WP 3.5.1. It is a very simple site, consisting solely of vanilla pages, no blog posts, and no fancy plugins used. I then exported it using the WP exporter. When I tried to upload it to my development server, to another WP 3.5.1 installation, which was brand new and completely empty with no activated plugins, I just got “failed to import” and “invalid post type” errors.

    Being able to develop locally and then upload to my development server so that clients can see it is a vital part of my workflow. Can anyone suggest what might be going wrong here? I note that the wordpress importer has not been tested on 3.5.1 – should I be developing on an earlier version of WP?!

    http://wordpress.org/extend/plugins/wordpress-importer/

Viewing 15 replies - 1 through 15 (of 19 total)
  • I’m also getting this. It’s incredibly annoying.

    Fresh WP install. No pages/content/other plugins. Went to import the data, it uploads fine, I get the “Assign Authors” and “Import Attachments” options but as soon as I click “Submit” on that page BAM “Failed to Import” message.

    How the heck are we supposed to import any of our data?

    Is there any news on this?

    I tried to contact the theme provider and they were unable to duplicate the issue. However this occurs on any 3.5.1 site that I try to import data to.

    Is there a server setting I should be looking for?

    This issue appears to be related to server settings.

    Tested this on a few different servers using the exact same theme/plugins/setup some servers it worked on, others it didn’t. In each instance the XML file does show that it uploads as it then loads the “Assign Authors” options.

    On server’s where the import works it lists the “Assign Authors” options similar to this (I was specifically trying to import WooThemes data hence the authors):

    1.Import author: WooThemes (wooadmin)
    or create new user with login name:
    or assign posts to an existing user:

    2.Import author: WooThemes (wooteam)
    or create new user with login name:
    or assign posts to an existing user:

    The server’s where it didn’t work would simply just display:

    1. Import author: ()
    or create new user with login name:
    or assign posts to an existing user:

    Anyone have any suggestions of what settings to check on the server’s to make sure this works properly?

    Same problem here. When i am going to import .xml file this error

    Failed to import “name” Invalid post type.

    I’ve tried several identical demo setups across multiple server’s and it honestly looks like it’s a server issue; possibly Apache. Some server’s it will work, some it will not

    Responses here seem few and far between from support but if I find a setting that I change that makes it work I’ll post it.

    Just to update I’ve tried changing a server (with the issue) from suPHP to FCGI with no luck. I’ve tried comparing PHP settings etc. they all look similar.

    Modules installed on the servers are all similar.

    Is there a specific module/variable in PHP or Apache etc. that we might be missing.

    Not only does it fail to import the data from the .xml files but it’s completely not recognizing any author’s etc. It’s like it will upload but not process any data; author’s don’t load and if you continue past that point in the import all data fails.

    If anyone has any tips on what variables/modules to change/implement please share.

    UPDATE: WORKAROUND FOR FAILED TO IMPORT

    Anyone having the issue where author’s are NOT being recognized or the XML import data is failing…

    I am not certain if this is something missing on the certain servers or if it’s the plugin itself is buggy as this it works for me on some server and not others using identical environments.

    If your import is failing try the following (this method resolved this issue for me):

    1) Download and Install 7zip.
    2) Right click on your .XML file -> 7zip -> Add to Archive
    3) Change the “Archive format” to gzip and hit “OK”
    4) Try to import the file again (using the .gz you just created) and it should work.

    I also had to bump up the following settings in my php.ini (these settings might be a bit excessive but my importer step 2 was going to a “page not found” front end error until I did this):

    memory_limit = 64M
    default_socket_timeout = 600
    pfpro.defaulttimeout = 600

    Thanks Syrehn! Worked perfectly with your workaround

    WOW! I try the Syrehn solution, ‘n this method work perfecly. Thx

    Thanks Amber, that was a huge help.

    Thanks!

    Howdy,

    I’m experiencing the same problem with an import (“invalid post type”) and I tried the .gz method but didn’t get any further. I’m trying to move data from the Badgestack plugin. Any suggestions for further troubleshooting?

    I had the same problem, I tried Syrehn solutions and it didn’t work, I tried it 2or 3 time and without any success, then I tried again with my XML file and it worked !
    So weird, maybe people who can’t solve the problem should just try several time.

    please help. Still doing this, does wordpress not care we are going through this.

    WPyogi

    (@wpyogi)

    Forum Moderator

    @angeldn3 – please start your own thread if you need help – see:

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘"Failure to import" and "Invalid post type" errors’ is closed to new replies.