Support » Plugin: WordPress HTTPS (SSL) » Failure to find permalink that has secure flag

  • Resolved brianbowles


    I am trying to install wordpress-https for a few pages for a shopping cart.

    I seem to remember it working a bit better previously, but it has been a couple weeks since I first installed. I have permalinks set to post name. https server is up and running, no certificate problems for the domain etc. However, when I create a simple page named test1 and go to it fails to find the file. The var/log/apache2/error.log says the file /var/www/test1 is not found.

    I deleted 3.2.2 after upgrading today and went back to 3.2.1. No luck. I now have 3.2.3rc1 installed and still the same problem. If I go to then it redirects to https, but then apache does not find the test1 file.

    I am using ubuntu and a vps, so I don’t think this is “shared ssl”.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mike Ems


    So does work?

    Yes, does work. If you are the developer and are interested in passswords to debug the issue, I’ll be happy to give them to you.

    Plugin Author Mike Ems


    And what if you go to without the plugin enabled?

    Same result. I double verified that the ssl is serving on the 443 port. The timeout code always happens 5 seconds later after the file not found error.

    [Sun Nov 18 05:50:13 2012] [info] Initial (No.1) HTTPS request received for child 3 (server
    [Sun Nov 18 05:50:13 2012] [error] [client] File does not exist: /var/www/test1
    [Sun Nov 18 05:50:13 2012] [debug] mod_deflate.c(615): [client] Zlib: Compressed 288 to 218 : URL /test1
    [Sun Nov 18 05:50:18 2012] [debug] ssl_engine_io.c(1908): OpenSSL: I/O error, 5 bytes expected to read on BIO#1209ce0 [mem: 120faf3]
    [Sun Nov 18 05:50:18 2012] [info] [client] (70007)The timeout specified has expired: SSL input filter read failed.
    [Sun Nov 18 05:50:18 2012] [debug] ssl_engine_kernel.c(1884): OpenSSL: Write: SSL negotiation finished successfully
    [Sun Nov 18 05:50:18 2012] [info] [client] Connection closed to child 3 with standard shutdown (server

    Actually I suppose this means there isn’t a problem with the plugin, but other pages worked.. grumble grumble.. maybe I’ll be able to figure it out soon or look at other plugins as the source of the problem.

    Meh, previous post is too old to fix now, but the file is served without https so it doesn’t appear to be a problem with my webserver. my problem is just not knowing php or wordpress well enough to know where the hook is on the url to see why it is failing to serve teh page under https. Guess I will try the 3.2.3 plugin and if it fixes things I’ll report as such.

    Plugin Author Mike Ems


    If the file isn’t being served over HTTPS, the problem is your web server or network. If it’s saying that “/test1” doesn’t exist in your server logs, it’s not even making it to WordPress.

    I just created a file.php and accessed it via https just fine. I just can not find any evidence that my web-server is broken. So if i create test1.php it would work, but i use a permalink on a wordpress page and get “file not found” in my apache logs.

    … and i chose wordpress because it seems simple with no frills… 🙁

    Now I have to learn low level wordpress code to try to track this down. Any pointers of what file/hook/function in the https plugin I should start with in order to debug this ?

    The problem ended up being that AllowOverrides was set to None under the https configuration. I assume this prevented the .htaccess file from being read. Because there was no .htaccess read, there were no mod_rewrite rules. So under http everything is rewritten to index.php, but https never had these rules in place so the ‘file not found’ messages in error.log. Thanks for your early support mvied. Unfortunately I started out on the wrong end trying to track this down.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Failure to find permalink that has secure flag’ is closed to new replies.