Support » Theme: SimplyBlack » Failure during WP 5.3 Update

  • Resolved Ӎuirén

    (@rhomani)


    I used SFTP into the site and switched WP_DEBUG to true and got the following. I assume that some aspect of the SimplyBlack theme is corrupted or accidentally deleted. Is it possible to edit the site, upload the files to restore it to operation?

    Warning: require_once(/srv/data/web/vhosts/raithold.org/htdocs/wp-admin/includes/class-custom-image-header.php): failed to open stream: No such file or directory in /srv/data/web/vhosts/raithold.org/htdocs/wp-includes/theme.php on line 2635

    Fatal Error: require_once(): Failed opening required ‘/srv/data/web/vhosts/raithold.org/htdocs/wp-admin/includes/class-custom-image-header.php’ (include_path=’.:/usr/share/php:/srv/data/web/includes’) in /srv/data/web/vhosts/raithold.org/htdocs/wp-includes/theme.php on line 2635

    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • amberflynn

    (@amberflynn)

    Hi, I got the exact same issue since I updated to 5.3. Can’t figure out how to fix this issue. Any help would be appreciated.

    sparklepaul

    (@sparklepaul)

    download 5.3 manually and get the 2 missing files (you’re only see the first error)
    class-custom-image-header.php
    class-custom-background.php

    Ӎuirén

    (@rhomani)

    I do that. Thanks.

    Theme Author Guido

    (@guido07111975)

    Hi,

    I notice you did not solve it yet? As already suggested you should upload the missing file: wp-admin/includes/class-custom-image-header.php

    Guido

    xbass540

    (@xbass540)

    hi,
    same here.
    I am getting errors for missing files, then i upload them from the new release but again i get the missing file message.
    Now i have uploaded the class-custom-image-header.php file in the wp-includes directory but still get

    Warning: require_once(/home/solomo25/public_html/blog/wp-admin/includes/class-custom-image-header.php): failed to open stream: No such file or directory in /home/solomo25/public_html/blog/wp-includes/theme.php on line 2635

    Fatal error: require_once(): Failed opening required ‘/home/mywebsite/public_html/blog/wp-admin/includes/class-custom-image-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/mywebsite/public_html/blog/wp-includes/theme.php on line 2635
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Theme Author Guido

    (@guido07111975)

    Hi,

    Now i have uploaded the class-custom-image-header.php file in the wp-includes directory but still get

    Seems you’ve uploaded file in wrong folder..

    It’s wp-admin > includes

    Guido

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.