Support » Plugin: Private Only » Fails to handle query string

  • There are a number of situations which result in the URL that displays the login screen having a query string. The most frequent (for me) is that when I logout of our private family website, the URL used to display the login screen is goold.net/wp-login.php?loggedout=true

    There is also a message on the login screen saying I’m logged out. If I now enter my user-id and password, the login fails and the screen is redisplayed.

    I limit the number of plugins I use. I thought it might be a conflict with “Captcha on Login”, but disabling it made no difference. Here is a complete list of my plugins:

    <ul>
    	<li>Akismet</li>
    	<li>Captcha on Login</li>
    	<li>Link Manager</li>
    	<li>NextGEN Gallery</li>
    	<li>Private Only</li>
    	<li>Private Only, Disable Feed (active)</li>
    	<li>TNG WordPress Integration</li>
    </ul>

    While you won’t be able to see the problem on my site (it is private, after all!), you can try reproducing it on your own private site.

    I worked around the problem by adding the following to my .htaccess file (before the WordPerfect section).


    RewriteEngine On
    RewriteCond %{REQUEST_URI} =/wp-login.php
    RewriteCond %{QUERY_STRING} ^.+$
    RewriteRule ^.*$ http://goold.net/wp-login.php? [L,R=302]
    `

    If you encounter this problem, you can use the above code — be sure to use your own domain name though!

    Regards,
    John Goold
    St. John’s NL Canada

    https://wordpress.org/plugins/private-only/

Viewing 1 replies (of 1 total)
  • Hmmm. What were those back-ticks for? They appear to “escape” the HTML markup.

    The “Put code in between backticks.” injunction could be reworded to be clearer (especially as there is no way to preview one’s post or edit one’s post after submitting it.

Viewing 1 replies (of 1 total)
  • The topic ‘Fails to handle query string’ is closed to new replies.