Support » Plugin: Really Simple CAPTCHA » Fails to display

  • I sometimes use ReCaptcha, sometimes Really Simple Captcha – this depends on the the client. Recently I’ve seen some problems with RSC in that it does not display.

    1) When I go into CF7 administration it is not enabled as a selection item.
    2) If I manually copy the captcha code from a working site, it does not display.

    In the case of the current project I temporarily disabled all other plugins besides CF7 and RSC. It made no difference. Looking at the page source I find the following above the Send button:

    <!– CF7 Modules –>
    <div style=’display:none;’><input type=”hidden” name=”_wpcf7_captcha_challenge_captcha-1″ value=”3463072360″ />captcha <span class=”wpcf7-form-control-wrap captcha-1″><input type=”text” name=”captcha-1″ value=”” size=”40″ class=”wpcf7-form-control wpcf7-captchar” autocomplete=”off” aria-invalid=”false” /></span></div>
    <!– End CF7 Modules –>

    I following the link to the PNG image and it was valid, yet no display. Any idea what is going on?

Viewing 3 replies - 1 through 3 (of 3 total)
  • It looks like when I entered the CF7 module text from the page view source, the forum editor stripped out part of the text including that which referenced the PNG image. Let’s try without the surrounding html:

    img class=”wpcf7-form-control wpcf7-captchac wpcf7-captcha-captcha-1″ width=”72″ height=”24″ alt=”captcha” src=”http://www.mysite.com/wp-content/uploads/wpcf7_captcha/3463072360.png&#8221; /

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    1) When I go into CF7 administration it is not enabled as a selection item.

    The tag-generator for Really Simple CAPTCHA doesn’t show up by default. This post explains how you can change the setting.

    https://contactform7.com/2015/09/17/contact-form-7-43/

    2) If I manually copy the captcha code from a working site, it does not display.

    The HTML source you posted looks a bit weird. Can I check the actual site?

    Not at this time; it’s under development and is restricted for that reason. I could send you the IP address but don’t want to publish that here.

    If you want I can send you a snapshot of the page source, the contact form region. However since I posted the original message I discovered a new twist.

    This site will have 2 forms, one for contact and one for testimonials. With both forms when I go into administration the captcha function does not display as an option. However, with the contact form when I copied in the captcha code like

    [captchac captcha-883] [captchar captcha-883]

    it displays and works on the frontend. So I created a third form using the form defaults adding only the captcha code. It also failed to display. Only the original form works.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fails to display’ is closed to new replies.