Support » Plugin: Optimize Database after Deleting Revisions » Fails on Cron & Shows incorrect server time

  • Resolved bhagawadkrishna

    (@bhagawadkrishna)


    I have Cron enabled from siteground server where my website bhagawadgeeta.com is hosted. The Cron works perfectly fine with other plugins.

    Its generating errors with your plugin. Report from siteground.com advanced technical help is enclosed here:

    I have tested it prior to replying, if you test it manually you will see that the one without a space generates an error.
    Code:

    bhagawad@sgp48 [~]# /usr/local/php70/bin/php-cli/home/bhagawad/public_html/wp-cron.php
    -bash: /usr/local/php70/bin/php-cli/home/bhagawad/public_html/wp-cron.php: Not a directory

    It appears you have a plugin causing issues, when I run the cron manually, it runs no problems but then other times it generates an error.

    Code:
    bhagawad@sgp48 [~]# /usr/local/php70/bin/php-cli /home/bhagawad/public_html/wp-cron.php

    EXPIRED – 1515082408
    <div id=”odb-start-buttons” class=”odb-padding-left”>
    <p>
    <input class=”button odb-normal” type=”button” name=”change_options” value=”Change Settings” onclick=”self.location=’options-general.php?page=odb_settings_page'”>

     
    <input class=”button odb-normal” type=”button” name=”view_log” value=”View Log File” onclick=”window.open(‘https://www.bhagawadgeeta.com/wp-content/plugins/rvg-optimize-database/logs/rvg-optimize-db-log.html’)”>
     
    <input class=”button odb-normal” type=”button” name=”delete_log” value=”Delete Log File” onclick=”self.location=’tools.php?page=rvg-optimize-database&action=delete_log'”>

     <input class=”button-primary button-large” type=”button” name=”start_optimization” value=”Start Optimization” onclick=”self.location=’tools.php?page=rvg-optimize-database&action=run'” class=”odb-bold” />

    </p>
    </div><!– /odb-start-buttons –>
    <script>jQuery(‘#odb-running’).hide();</script>

    I disabled rvg-optimize-database and it runs without any issues each time:

    Code:
    bhagawad@sgp48 [~]# /usr/local/php70/bin/php-cli /home/bhagawad/public_html/wp-cron.php
    bhagawad@sgp48 [~]# /usr/local/php70/bin/php-cli /home/bhagawad/public_html/wp-cron.php
    bhagawad@sgp48 [~]#

    No output means that it ran successfully, by default the cron will not return anything.

    If you require any further assistance don’t hesitate to let us know.

    NEXT ISSUE: Time shown on your plugin page is the UTC time and not the server time. Not only that it shows next schedule is 31st December 2017 …. as in time from the past for next schedule.

    Can you please audit this and help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author cageehv

    (@cageehv)

    Hey bhagawadkrishna,

    1) Cron errors
    To be honest: I have no idea what the issue is…
    Did you try to disable all plugins except for mine? Might be clashing plugins…
    Other possibility: some issues with the server settings.
    So far, there were no reports of scheduler errors.

    2) Time issues
    You are right, there were some issues with the server time settings.
    I fixed them and just released v4.4.3 of my plugin.

    Thanks for your feedback,
    Rolf

    Hi Rolf,

    I updated to 4.4.3 this morning and the plugin changed the UTC time displayed in the WP settings to my local time. Deactivating the schedule did not fix the issue, I had to deactivate the plugin.

    As soon as I deactivated the plugin the UTC time was displayed correctly. I reactivated and deactivated the plugin a second time just to be sure and got the same result.

    I’m also on Siteground and they confirmed the server TZ database is correctly set up.

    Cheers,

    Martin.

    Plugin Author cageehv

    (@cageehv)

    Thanks for your feedback, Martin!

    peace,
    Rolf

    Hello Rolf,

    I tried to update the plugin on a new site late last night and it failed with white screen, citing possible permission issues. I finally succeeded, but found inexplicable code in the new WP installation core files, so feared it had been attacked, during the installation although Wordfence had found nothing. I reinstalled WP and your plugin and all seemed OK.

    Today I installed on 4 localhost and 6 servers with the message:
    Notice: date_default_timezone_set(): Timezone ID '' is invalid in \wp-content\plugins\rvg-optimize-database\rvg-optimize-database.php on line 84.

    I discovered that on some, including the one yesterday, it had changed the server time by +7 hours. The difference being that, if a city is used to set the timezone, this time advance occurs, but if the manual UTC time is used it does not change the time. This may provide a pointer.

    I saw after posting that this was considered resolved, so I have posted again.

    • This reply was modified 1 year, 3 months ago by  Malae. Reason: Was marked resolved, so noted that I have posted again
    • This reply was modified 1 year, 3 months ago by  Malae.
    Plugin Author cageehv

    (@cageehv)

    Hey Malae,

    Question: what is your ‘Timezone’ setting of the site(s)? (settings > general)

    Thanks for your feedback!

    Rolf

    Some are set to Jakarta and some to UTC+7. Using city time advanced the server time by 7 hrs. The PHP notice applies to all.

    Yesterday after the plugin crashed WP on a brand new WP installation (no content), I found many lines of Spanish (es-ES) in my core files and my site uses (en-GB). I suspected the plugin had been compromised, but after reinstalling WP and the plugin, it had disappeared.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fails on Cron & Shows incorrect server time’ is closed to new replies.