• User

    (@whitelionstudio)


    I always use this plugin, but when installing an shop it interferes with card payments. Very bad, can not be used.

    • This topic was modified 4 years, 2 months ago by User.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Hi Manu,

    Can you provide more specifics about the issue you’re having? What shop are you using, and in what way does it interfere?

    If you provide steps to reproduce the issue, we’ll be happy to resolve it.

    Michael

    Thread Starter User

    (@whitelionstudio)

    Hello michael, plugin interferes with the redsys (http://www.redsys.es/en/index.html) payment platform with woocommerce. Having activated your plugin, you can make card payments in my online store but it shows me each new order as pending payment. Somehow it blocks the url back to the store with a 503 error and the status of the orders are not updated correctly.
    steps:
    To reproduce the error you need a Point-of-Sale Terminal connected to the redsys plugin.
    Then when making a purchase with card, website will show that it is correct, but when accessing to “my account”, the status of the order appears as pending payment.

    In the Point-of-Sale Terminal appears that there has been a 503 error on the process.

    Deactivating the plugin disappears the error and everything works as it should.

    • This reply was modified 4 years, 2 months ago by User.
    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Did you have the Bad Bots module active? If so, disable that module, and make sure there’s no All in One SEO Pack section in .htaccess.

    @whitelionstudio,

    Manu which RedSys plugin are you using?

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    @whitelionstudio

    If you contact us here, we’d like to look into this issue further and get it working for you. https://semperplugins.com/contact/

    Thread Starter User

    (@whitelionstudio)

    This issue has been fixed.
    I have disabled only the Block bots using HTTP option that was causing the 503 error.
    In the blocked botlog, attempts to connect to the redsys platform appear.
    I hope you can solve the error of that module in next updates.

    Thanks for the help

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Can you copy/paste the exact information from the log?

    Thread Starter User

    (@whitelionstudio)

    2017-02-20 21:38:36 Bot bloqueado con la IP XXX.XXX.XXX – se ha encontrado el agente de usuario Java/1.5.0 en la lista de bloqueo.

    other lines are basically the same, changes only in java version.

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    In that case, since you’re using Java to connect to your site, you can still use the Bad Bots module if you select Use Custom Blocklist and remove the Java entry.

    Java user agents on most sites are unwanted bots, usually content scrapers, which is why this module blocks them.

    I would appreciate it if you would change the rating.

    Thread Starter User

    (@whitelionstudio)

    ok rating change. thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fails in shop with cards payments’ is closed to new replies.