Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Khang Minh

    (@oddoneout)

    Hi there,

    Have you tried what was suggested here: https://wordpress.org/support/topic/getting-a-404-when-clicking-on-click-to-generate-your-sitemap-index?replies=8

    If that doesn’t help, let me know.

    Can I have a list of active plugins on your site? You can send the list via https://betterwp.net .

    Also, could you please kindly reconsider the rating?

    This is all very confusing because I read that since v4 of WP there are no sitemap files and a virtual one is created when required, so why does the widget take you to file that’s not required but not being generated anyway?

    All sitemaps are virtual since day one, so I’m not sure where you get the above information from.

    Hi Khang

    I replied to you directly by email yesterday as soon as I got your response, this is one I said:

    1. I flush the cache
    2. I save the changes
    3. I fail to generate the sitemapindex.xml

    Exactly the same problem.

    Your second point.

    <so I’m not sure where you get the above information from>

    I get it when I click the generate button that fails to create a file called sitemapindex.xml, but if the xml is generated on the fly why is it required anyway even though it’s not being generated?

    As for the rating – I really want this to work but until it does what can I do? It simply doesn’t work for me.

    Bruce.

    Plugin Author Khang Minh

    (@oddoneout)

    Can you navigate to Settings >> Permalinks and then press Save changes? Please try generating the sitemap again after that.

    Let me know if it still doesn’t work.

    Hi Khang

    That did the trick!

    All is now working and I’ve reviewed my rating up.

    Why did saving the permalinks fix the problem?

    I’ll review it again in a couple of weeks after looking at the results for my site.

    Thanks for your prompt help.

    Bruce.

    Plugin Author Khang Minh

    (@oddoneout)

    Glad you got it working! And thanks for re-considering your review.

    BWP Sitemaps requires flushing rewrite rules once, which should be done right after you activate the plugin. However for some reasons your rewrite rules weren’t flushed correctly, which results in “Page not found” error you saw.

    I suspect this is an incompatibility issue with another plugin. That’s why I asked if you could provide a list of active plugins on your site. If you don’t mind, can you do so via https://betterwp.net/contact/ ? Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Failing to produce sitemapindex.xml file’ is closed to new replies.