Support » Fixing WordPress » failed upgrade – error in wp-settings file

  • Hi all,

    This afternoon while automatically updating a friend’s site to 3.4.1 my connection dropped. Now the site’s down: Here’s the error:

    Fatal error: require() [function.require]: Failed opening required ‘/home/a2162228/public_html/wp-includes/load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a2162228/public_html/wp-settings.php on line 21

    I’ve followed the instructions here precisely already…backed up the wp-content folder, replaced wp-admin, wp-includes and all of the files in the root directory from a fresh WordPress download. I’ve also tried deleting and re-uploading the load.php file that’s called out in the error, but that hasn’t worked either.

    Any ideas? Your help is very appreciated! Thank you!!

Viewing 1 replies (of 1 total)
  • Restore from the backup you made prior to the upgrade. Right?


    Start from a fresh wp-content folder, using the 2011 theme. If that doesn’t fire up just do a blanket new install, of course keeping your old wp-content folder handy as wp-contentold or something.

    Move you theme and plugin directories over. Switch to your old theme and activate your plugins one by one. Then move your uploads file over. That way you can tell if something is fried individually.

Viewing 1 replies (of 1 total)
  • The topic ‘failed upgrade – error in wp-settings file’ is closed to new replies.