Support » Fixing WordPress » Failed to write file to disk when uploading

  • When I try to upload any file in the ACP I get the “Failed to write file to disk” error. I’ve searched and tried all the solutions but non work.

    Anyone have some insight to this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    The ACP? Do you mean that you can’t upload any media (images, pdfs etc)? Have you spoken to your hosting provider about this?

    Today I found the same problem, and the text under on wordpress forum as solution. But don’t know, will it work or not. The discussions to that thread were closed, so posted here…

    By EricRihlmann:
    “Today I started experiencing this issue as well after successfully uploading several photos. I did an extensive search on this forum and Google I was amazed to not find a clear resolution. This lead me to searching through the WordPress core files for the error message to see what was going on. The error message seemed to be triggered after the file was uploaded to the temporary directory where php stores the newly uploaded file. I did not have access to this directory, so I contacted my host and they were able to repair/remove the temporary files in the directory. This immediately resolved the issue for me and I hope this helps resolve it for all of you.”

    I did’t do that, but I even don’t know how my problem get solved as I did nothing. A gap of few mins for reading the possible solutions of the problem and again a try did the thing for me, without doing anything. Don’t know the reason and the problem..still a mystery for me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Failed to write file to disk when uploading’ is closed to new replies.