The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

"Failed to write file to disk" in 2.8.4 (5 posts)

  1. Davis Ray Sickmon Jr
    Posted 7 years ago #

    I've got two WordPress sites that have developed problems after updating to 2.8.4. Attempting to upload pictures or media results in the following error:

    Failed to write file to disk

    The drive isn't full, and permissions for the upload directory (and all subdirectories) is 755 and worked just fine before. Any thoughts?

  2. Samuel B

    Posted 7 years ago #

    try one upload with /wp-content and /uploads and all folders under it chmod 777
    after that all should work at 755.

  3. Davis Ray Sickmon Jr
    Posted 7 years ago #

    Tried it - didn't work. Just to make sure, I manually uploaded stuff into the directory via FTP - no problems there. Error occurs both in browser upload and flash upload. And, just for the heck of it, I tested it in multiple browsers - happens in Safari and Firefox both.

    Any other ideas?

  4. EricRihlmann
    Posted 6 years ago #

    Today I started experiencing this issue as well after successfully uploading several photos. I did an extensive search on this forum and Google I was amazed to not find a clear resolution. This lead me to searching through the WordPress core files for the error message to see what was going on. The error message seemed to be triggered after the file was uploaded to the temporary directory where php stores the newly uploaded file. I did not have access to this directory, so I contacted my host and they were able to repair/remove the temporary files in the directory. This immediately resolved the issue for me and I hope this helps resolve it for all of you.

  5. bh_WP_fan
    Posted 6 years ago #

    Have you tried:
    - Deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - Switching to the default theme to rule out any theme-related problems?

    - Resetting the plugins directory in phpMyAdmin, and/or renaming it through FTP? Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.