Support » Installing WordPress » Failed to upgrade from 3.0 to 3.1

  • Resolved Kos Mos

    (@siravecavec)


    Warning: copy(/srv/www/plev.eu/public_html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /srv/www/plev.eu/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Line 200 has this:
    return copy($source, $destination);

    What can I do?

Viewing 10 replies - 1 through 10 (of 10 total)
  • My upgrade failed, nothing happened at all so I uploaded the files via ftp. Have you tried this first?

    @mscrow yes I managed it by changing files permissions.

    I tried to upgrade my wp from 3.0 to 3.1 but i couldn’t what can i do and i like to no if am reliable to get it done

    I ran the auto-update from 3.0.5 to 3.1 and it appeared to work, except that now when I try to log in I get a page that says “No database update is necessary”.

    Any suggestions?

    esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to try logging into your site to get this to kick in fully.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-running the upgrade manually using wp-admin/upgrade.php.

    esmi,

    Thanks, but no joy.

    1 – Switching the theme by renaming the current themes folder just results in a blank page, even after trying to force a login.

    2 – Resetting the plugins folder by fiddling the database has no effect. The same No Update Is Necessary page still appears when I try to go to the dashboard.

    3 – Rerunning the upgrade using wp-admin/upgrade.php has the same effect as your second suggestion.

    It appears to be running 3.1 because I can see the new (ugly) admin bar atop the front page. …but it’s pretty useless ’cause there’s no way to add content without being able to get to the dashboard. Choosing anything from the new admin bar just brings up the No Update Necessary page again.

    hello every one. here is my blog http://www.amcy5.com/blog

    I installed 3.1 with no display, the whole installation was ok, i was using 3.0.5 version before this, I made new installation rather than updating. i am using windows server.

    Regards,

    Muhammad Samiullah

    I installed 3.1 on my blog http://www.dotcompromotions.com.au/blog/ and had to do it manually as the same warning came up. I suggest that you follow the instructions for manual updating as they will probably take quite a while to fix the bug.

    No one even seems to know what it is that is causing sites to fail automatic upgrade.

    The blog used to manually upgrade to 3.0.5 then it just stopped upgrading at 3.1. Dont believe them when they blame your server etc.

    David

    I had the same problem, and going to the same file and running CHMOD 777 fixed the problem and it upgraded automatically.

    I am having this issue as well, what file are you chmodding to 777? the wp-admin/includes/class-wp-filesystem-direct.php ?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Failed to upgrade from 3.0 to 3.1’ is closed to new replies.