Support » Fixing WordPress » Failed to submit comment – 404 error

  • dulotie

    (@dulotie)


    Failed to submit comment. click submit will lead to 404 error- page not found.

    have tried changing themes, re-save permalinks, recheck permalinks (no space)

    What seems to be the problem?

    http://imelvin.com/

Viewing 8 replies - 16 through 23 (of 23 total)
  • Jason

    (@jaffydesigns)

    Hi there!

    I was having the exact same issue, and managed to get it working again. I had an errant space at the end of the “Custom Structure” of the Permalink Settings, and it’s what was causing the “//” to appear in the comment URL that you get taken to upon submission (i.e. the broken url).

    Make sure there are no spaces in that field, and it should fix it right up.

    Hope that helps!

    Jason

    Anton

    (@doordebenen)

    None of the above suggestions helped for me. Can anyone please advise me?? Thanks, i am getting pretty desperate now…

    Anton

    (@doordebenen)

    Still no advice??

    Jason

    (@jaffydesigns)

    Hi doordebenen

    I’m no expert, but I do know that “%20” is a substitution for a space in a URL, and it’s showing up in the URL you quoted (http://mydomainname/mypostname/%20/comment-page-1#comment-7) – it means that you have a space somewhere where it shouldn’t be. In my case, it was in the “Custom Structure” field. I’d suggest making doubly sure you have no spaces in any of the URL fields.

    Sorry I can’t help more – I saw you having the same problem as me, and the fix I described worked like a charm.

    J

    I was having this same problem. And it wasn’t the permalink structure. The file wp-comments-post.php was missing from the server. Someone must have deleted it. Once I put a new copy there, everything is fine.

    I was having the same problem yesterday. I turn the permalinks to default save it and then re-custom again as I wish. and it solved.

    Anton

    (@doordebenen)

    The problem has finally been solved. The solution was very simple. Go to settings of your comments and disable (uncheck) “break comments into pages”.
    Thanks to http://www.wphulp.nl/forum/

    SS_Minnows comment helped me greatly.

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Failed to submit comment – 404 error’ is closed to new replies.