Support » Fixing WordPress » Failed to submit comment – 404 error

  • Failed to submit comment. click submit will lead to 404 error- page not found.

    have tried changing themes, re-save permalinks, recheck permalinks (no space)

    What seems to be the problem?

    http://imelvin.com/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Did you try deactivating all plugins? What about setting permalinks to Default?

    yes, it turns out the same. I even deleted un-use plugins from the ftp

    Does the file wp-comments-post.php exist on your server?

    it’s there..

    What about setting permalinks to Default?

    Did you see any errors after submitting these changes within the admin?

    Do you have access to your .htaccess file? If so, and there are any contents within it, try to empty it and post the outcome.

    I don’t have any problem setting permalinks back to default.
    Message showed: permalinks structure updated.
    submitting comment after that shows:

    Not Acceptable

    An appropriate representation of the requested resource /wp-comments-post.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    This is the content within .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    U mean update an empty .htaccess file back to the server?

    U mean update an empty .htaccess file back to the server?

    Yes, you can simply rename the .htaccess file to htaccess.txt then see if that that fixes the error.

    It’s still the same =X

    Renaming the .htaccess file will cause Permalinks not to work and I’m not sure what the test is meant to prove. However, it seems like your error message is telling you that your theme is missing an expected file (wp-comments-post.php). Does it happen if you switch to the Default theme?

    the same problem occur. I’m trying to download wordpress again and replace the old wp-comments-post.php.

    Still no luck.

    bump

    I assumed it was looking for something in the theme but wp-comments-post.php is a core wordress file. Did you try uploading the wordpress core files from a fresh download?

    I’m having the same issue. After submitting a comment, the URL goes to:
    http://mydomainname/mypostname//comment-page-1#comment-7

    and displays: “Error 404 – Not Found
    Sorry, the page that you are looking for does not exist.”

    However, the comment does get saved and it can be viewed on:

    http://mydomainname/mypostname/%20/comment-page-1#comment-7

    My permalink setting is: /%postname%/

    I changed it to default and the comments are working ok, but I don’t really want to change my custom permalink. What should I do? Any suggestions?

    after changing it to default, did you try going back to custom? sometimes you just have to save to default then back to cutom to reset things

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Failed to submit comment – 404 error’ is closed to new replies.